Unable to verify license key error (build 4.0.9.3)

Think you've found a bug? Post a description here.

Moderator: Serin

Unable to verify license key error (build 4.0.9.3)

Postby WonderGamer » Mon Apr 18, 2011 10:39 am

This newest build has rendered my server unusable. Everytime I start it up, I get the following error:
Unable to verify license key: License was not in a valid format
I have had a few of my buddies try to connect to it & have even tried connecting to it myself, none of which have succeeded since the last update.

I have tried fully uninstalling (clearing all files in the installation location & Documents and Settings folders) & reinstalling, but this did not correct the issue. I've even tried installing an older version of Cerberus FTP server; this did not work either.

What I find odd about this is that I was using it for personal use, so why exactly is it looking for a license key to begin with? Does your service not allow for personal use servers anymore? Or do we need to register regardless of whether it's for business and/or otherwise?
WonderGamer
New User
 
Posts: 6
Joined: Mon Apr 18, 2011 10:29 am

Re: Unable to verify license key error (build 4.0.9.3)

Postby Serin » Mon Apr 18, 2011 11:06 am

Hello,

This latest build added a lot of additional logging around license verification to resolve an issue another customer was having but otherwise the functionality should be identical to 4.0.9.2 and below. We still allow Personal use licensing but the server always (and has always) looked for a license key at startup. If the license is empty then is skips actually checking the key but there must have been something in the configuration file for the license key for the code to get that far. However, an invalid license key simply makes Cerberus go into Personal mode.

How about posting a full startup log so I can see what is going on?
User avatar
Serin
Site Administrator
 
Posts: 1469
Joined: Sat Jan 01, 2005 7:57 pm
Location: United States

Re: Unable to verify license key error (build 4.0.9.3)

Postby WonderGamer » Mon Apr 18, 2011 2:02 pm

Unsure if this is what you're talking about, but this is the best I could come up with:

[2011-04-18 11:59:33]: ERROR [server] - Unable to verify license key: License was not in a valid format
[2011-04-18 11:59:33]: SYSTEM [server] - AMD Phenom(tm) II X4 975 Processor with 1 Processor, 4 Cores
[2011-04-18 11:59:33]: SYSTEM [server] - Microsoft Windows XP Home Edition
[2011-04-18 11:59:33]: SYSTEM [server] -
[2011-04-18 11:59:33]: SYSTEM [server] - Cerberus FTP Server 4.0.9.3 - Personal started on 'gaming'
[2011-04-18 11:59:33]: SYSTEM [server] - Installed as a Windows Service but started in application mode
[2011-04-18 11:59:33]: SYSTEM [server] -
[2011-04-18 11:59:33]: SYSTEM [server] - Interface 0 (FTP) listening at 192.168.0.10 on port 21
[2011-04-18 11:59:36]: SYSTEM [server] - WAN IP detected as 67.2.111.88
[2011-04-18 11:59:49]: SYSTEM [server] - Shutting down the server
[2011-04-18 11:59:49]: SYSTEM [server] - Shutting down local Interface 0 listening on 192.168.0.10
[2011-04-18 11:59:49]: SYSTEM [server] -

If you are talking about some logs located elsewhere, I will need to know where to look for those.
WonderGamer
New User
 
Posts: 6
Joined: Mon Apr 18, 2011 10:29 am

Re: Unable to verify license key error (build 4.0.9.3)

Postby Serin » Mon Apr 18, 2011 2:36 pm

That was indeed the log I was referring to.

The error was always there we just didn't log it before. I'm fairly certain it is not the cause for whatever problems you are having.

I would first check that the firewall isn't the problem. Make sure Cerberus was correctly re-added to the firewall on install. Try disabling the firewall and trying to connect again.
User avatar
Serin
Site Administrator
 
Posts: 1469
Joined: Sat Jan 01, 2005 7:57 pm
Location: United States

Re: Unable to verify license key error (build 4.0.9.3)

Postby WonderGamer » Mon Apr 18, 2011 4:38 pm

I've checked that. I have Norton set to notify me whenever a program needs to access the internet; this inludes recently changed programs, in which case I get a prompt to allow it again.

In the past with version 4, I've disabled the Cerberus FTP Server service after an update (seeing as I would rather the service was not running on my computer 24/7). This is indicated by the Installed as a Windows Service but started in application mode line. I would still let me run the server & allow others to connect regardless of whether the service was running or not.

UPDATE: Seems that the issue may have been fixed, although I'm still get the error previously mentioned. So long as people are able to connect, the error doesn't bother me. Just appears that the few users I have can no longer use their browser to access it; FTP clients seem to work, though. Was there anything in the last update that would be conflicting with being accessed from a web browser (IE has been the only one that has worked properly with my server so long as passive mode was disabled, which no longer does anymore).
WonderGamer
New User
 
Posts: 6
Joined: Mon Apr 18, 2011 10:29 am

Re: Unable to verify license key error (build 4.0.9.3)

Postby Serin » Mon Apr 18, 2011 10:27 pm

Check the settings.xml file and empty out or delete the <serialNumber> tag. That should get rid of the error. I will probably make that particular logging statement a debug statement in the next build.


If passive isn't working I would check your IP settings to make sure your WAN IP hasn't changed, or that your port forwarding settings are still valid. Even though you've checked your firewall settings I would still disable it and try again to make sure that the firewall isn't the culprit.
User avatar
Serin
Site Administrator
 
Posts: 1469
Joined: Sat Jan 01, 2005 7:57 pm
Location: United States

Re: Unable to verify license key error (build 4.0.9.3)

Postby WonderGamer » Tue Apr 19, 2011 12:05 am

The fact that passive mode isn't working is likely my doing. I'm not willing to forward more ports that are needed, so I'm only forwarded ports 20 & 21 so people could connect to my server through non-passive connections. I already have instructions for my friends on how to get it to work, so that has worked in the past.

The firewall would not be the reason anyways seeing as one of my buddies was able to connect to it through the browser when I tested it earlier today (unsure what browser he was using, however). I forgot to mention that I had already done what you said with the firewall settings, which didn't make a difference.

The problem appears to be with browsers, not FTP clients, so I'm not entirely sure what the problem is there. I've tried changing around my security settings in IE, but so far have not succeeded in getting it to work with my browser.

I will try what you said with deleting the serial in the settings.xml file & will post back to let you know if it fixed the browser-access issue or not.
WonderGamer
New User
 
Posts: 6
Joined: Mon Apr 18, 2011 10:29 am

Re: Unable to verify license key error (build 4.0.9.3)

Postby Serin » Tue Apr 19, 2011 12:12 am

The serial number fix will not solve any client problems. It should simply get rid of the annoying error message.

It sounds like you know what needs to be done to fix passive mode. If you aren't willing to enable port forwarding for the passive port range then you will be stuck with active FTP mode. Clients can certainly make that work. However, that mode working is completely dependent on the client used and in their firewall/network setup. Nothing can be done on the FTP server end to ensure that active mode works for a client.
User avatar
Serin
Site Administrator
 
Posts: 1469
Joined: Sat Jan 01, 2005 7:57 pm
Location: United States

Re: Unable to verify license key error (build 4.0.9.3)

Postby WonderGamer » Tue Apr 19, 2011 12:24 am

Passive mode isn't likely the problem either. I still get the same error (error below) when I try to access it through the network where passive mode should not be an issue with network connections. Passive mode is only an issue with internet connections because I haven't forwarded the ports to enable passive mode.

Clearing the serial did fix the error, but as you said didn't nothing with accessibility issues. I know it's not my browser seeing as everything was working fine (with my friends & myself) up until I updated the server 2 days ago. FTP clients seem to work, so I'll just make a note on my blogs that people will have to use a client until this issue is resolved. Until then, I'm still looking for a fix for this problem.

EDIT: Forgot to post the error:
http://img268.imageshack.us/img268/2571/ftperror.jpg
WonderGamer
New User
 
Posts: 6
Joined: Mon Apr 18, 2011 10:29 am

Re: Unable to verify license key error (build 4.0.9.3)

Postby Serin » Tue Apr 19, 2011 12:38 am

Hello,

I will need to see the Cerberus FTP Server log showing the connection attempt.
User avatar
Serin
Site Administrator
 
Posts: 1469
Joined: Sat Jan 01, 2005 7:57 pm
Location: United States

Re: Unable to verify license key error (build 4.0.9.3)

Postby WonderGamer » Tue Apr 19, 2011 3:56 am

I guess I have nobody to blame except myself on this one. I forgot I was restricting port usage on my browser through my firewall & had not re-allowed port 21 once it updated. This made it so the signal was never being sent to my server from my browser because port 21 was blocked. It wasn't an issue with the server afterall (other than the error I was getting). I didn't realize this was the case until your last post, at which point it all made sense; my server was getting a signal from my client, but not from by browser.

Anyways, thank you for your time. I'm sorry it took this long before I realized that the problem was my firewall blocking IE, not the server. Thank you for helping me to realize that. Peace!
WonderGamer
New User
 
Posts: 6
Joined: Mon Apr 18, 2011 10:29 am


Return to Report a Bug

Who is online

Users browsing this forum: Bing [Bot] and 1 guest