2.3 closing connections abnormally

Home Forums General Report a Bug 2.3 closing connections abnormally

  • This topic is empty.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #28911
    omascia
    Participant

    I’m new to Cerberus FTP Server which I downloaded for testing some days. I am not new to FTP, though. The product looks attractive and seems to fit all my needs. Except that I have a reliablity problem. Connections seems to reset abnormally, but regularly. This can be seen best by connecting to the server using Firefox browser, but I got it also with Apple Safari 2.0 (these two beasts are enough different to not suspect a common bug on their side). I have though to agree I did not saw yet the bug using Microsoft IE, but unfortunately I and my relations don’t care about IE and don’t use it.

    Using Firefox (on Win32) and Safari (on OS X.4) when I log to my test server (anonymous login), the content of the server root directory displays or does not display (so not always). Then when clicking on some subdirectories, they either appear or appear as a blank page. When they appear as a blank page, forcing the browser to refresh makes them appear.

    Using Firefox (on Win32), download a big file, the transfer seems to run fast and nicely then stops abruptly around the end, the downloaded file is truncated. Reproduceable, but not always, even for the same file.

    I have the vague feeling that those directories with a lot of content are those that don’t display correctly at first, until forced to reload.

    The test machine is running Win XP SP2 (US) with all and every patches, drivers and updates as offered by Windows Update.

    Here is a log session where Firefox displayed a blank page upon clicking on a a directory link:

    Tue Jun 14 15:55:06 2005 8 PASV

    Tue Jun 14 15:55:06 2005 8 227 Entering Passive Mode (192,168,0,16,39,21)

    Tue Jun 14 15:55:06 2005 8 SIZE /ServicePacks/Windows2000/

    Tue Jun 14 15:55:06 2005 8 213 0

    Tue Jun 14 15:55:06 2005 8 Connection with data socket accepted

    Tue Jun 14 15:55:06 2005 8 MDTM /ServicePacks/Windows2000/

    Tue Jun 14 15:55:06 2005 8 213 20040127073508

    Tue Jun 14 15:55:06 2005 8 RETR /ServicePacks/Windows2000/

    Tue Jun 14 15:55:06 2005 8 150 Opening data connection

    Tue Jun 14 15:55:06 2005 8 Unable to open file: Access is denied.

    Tue Jun 14 15:55:06 2005 8 The data connection was closed by the remote socket

    Tue Jun 14 15:55:06 2005 8 550 File transfer failed

    Tue Jun 14 15:55:07 2005 8 PASV

    Tue Jun 14 15:55:07 2005 8 227 Entering Passive Mode (192,168,0,16,39,22)

    Tue Jun 14 15:55:07 2005 8 CWD /ServicePacks/Windows2000/

    Tue Jun 14 15:55:07 2005 8 250 Change directory ok

    Tue Jun 14 15:55:07 2005 8 Connection with data socket accepted

    Tue Jun 14 15:55:07 2005 8 LIST

    Tue Jun 14 15:55:07 2005 8 150 Opening data connection

    Tue Jun 14 15:55:07 2005 8 The data connection was closed by the remote socket

    Tue Jun 14 15:55:07 2005 8 226 Transfer complete

    Here is the same log, right after clicking refresh in the browser and have obtained the directory listed correctly :

    Tue Jun 14 15:57:49 2005 9 PASV

    Tue Jun 14 15:57:49 2005 9 227 Entering Passive Mode (192,168,0,16,39,23)

    Tue Jun 14 15:57:49 2005 9 SIZE /ServicePacks/Windows2000/

    Tue Jun 14 15:57:49 2005 9 213 0

    Tue Jun 14 15:57:49 2005 9 Connection with data socket accepted

    Tue Jun 14 15:57:49 2005 9 MDTM /ServicePacks/Windows2000/

    Tue Jun 14 15:57:49 2005 9 213 20040127073508

    Tue Jun 14 15:57:49 2005 9 RETR /ServicePacks/Windows2000/

    Tue Jun 14 15:57:49 2005 9 150 Opening data connection

    Tue Jun 14 15:57:49 2005 9 Unable to open file: Access is denied.

    Tue Jun 14 15:57:49 2005 9 The data connection was closed by the remote socket

    Tue Jun 14 15:57:49 2005 9 550 File transfer failed

    Tue Jun 14 15:57:49 2005 9 PASV

    Tue Jun 14 15:57:49 2005 9 227 Entering Passive Mode (192,168,0,16,39,24)

    Tue Jun 14 15:57:49 2005 9 CWD /ServicePacks/Windows2000/

    Tue Jun 14 15:57:49 2005 9 250 Change directory ok

    Tue Jun 14 15:57:49 2005 9 Connection with data socket accepted

    Tue Jun 14 15:57:49 2005 9 LIST

    Tue Jun 14 15:57:49 2005 9 150 Opening data connection

    Tue Jun 14 15:57:49 2005 9 The data connection was closed by the remote socket

    Tue Jun 14 15:57:49 2005 9 226 Transfer complete

    I don’t see evident reason through these logs.

    What are other users experience with 2.3 ?

    #33075
    omascia
    Participant

    I have read in another thread that some user seemed to have the following issue :

    Quote:

    I found that if I tried to upload anything other than a very small file my connection would timeout and the upload would fail.

    After trying many things, I learned that turning off “Simple Directories” corrected the problem.

    I also have Simple Directories activated for anonymous user. Because I want some specific directory tree to be offered as “root” to the anonymous user. Could it be that somehow my downloads and LIST issues might be too related to this ? I have yet to check but will report again if I see difference in the behaviour.

    #33076
    omascia
    Participant

    Quote:


    Quote:

    I found that if I tried to upload anything other than a very small file my connection would timeout and the upload would fail.

    After trying many things, I learned that turning off “Simple Directories” corrected the problem.

    Could it be that somehow my downloads and LIST issues might be too related to this ? I have yet to check but will report again if I see difference in the behaviour.

    Okay, checked, stopping the server, changing user settings and restarting server, same issues.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.
Close Cart

Shopping Cart