Clients cant download files.

Home Forums General Firewall Help Clients cant download files.

  • This topic is empty.
Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #28538
    Anonymous
    Participant

    hello

    all client users cant download from my ftp server.

    i put the pc the server is running on into the dmz of my router built-in firewall so it shouldnt be kind of firewallproblem.

    do client users also have to configure their firewall so they can download?

    probably not…

    the OS on this computer is win98 but that shouldnt make any difference i thing.

    could someone help please, i need a working ftp server

    greetz

    #32471
    Anonymous
    Participant

    some specification: they CAN download files but they all contain no data

    the filesize is always 0 kb

    greetz

    #32472
    Anonymous
    Participant

    some specification: they CAN download files but they all contain no data

    the filesize is always 0 kb

    greetz

    #32473
    Anonymous
    Participant

    Using CuteFTP client.

    #32474
    Anonymous
    Participant

    Sorry.

    I having same prob. Client using CuteFTP, can upload no problem but downloading leaves a 0Kb file on client and then opens up multiple download attempts on server eventually hanging the server.

    Anyone with a solution? (soz, was intending to search for solutions but this thread is the exact same prob as mine)

    Many thanks!

    Mush

    #32475
    renke
    Participant

    did you try any other clients? the free smart-ftp works fine

    #32476
    Anonymous
    Participant

    Yes, tried IE Browser and a DOS FTP session but get best results with CuteFTP 6 Professional.

    I want to use CuteFTP, surely it is something I am doing wrong or haven’t set up correctly that won’t let me DL files from the server?

    It DL’s small files without a problem, its the large files it struggles with. The server will begin transfer, hang on 30%, then create a new transfer. Again and again until server hangs and client only has a 0Kb file recv’d. :/

    Any input much appreciated!

    Kind Regards

    Mush

    #32477
    renke
    Participant

    i can’t verify your problem.

    i tried cuteftp pro 6.0 (only dl on localhost but …) and the transfer of a 700mb-file works without failures.

    log cuteFTP:

    STATUS:> Transferring file “/test/trailer, 3d & schnickschnack/gerhard polt/gpolt3.MPG”…

    COMMAND:> TYPE I

    200 Type Binary

    COMMAND:> PASV

    421 PASV command failed

    STATUS:> PASV failed, trying PORT.

    // this failure happens sometimes with different client

    COMMAND:> PORT xx,xx,171,79,15,79

    200 Port command received

    COMMAND:> RETR gpolt3.MPG

    150 Opening data connection

    226 Transfer complete

    STATUS:> Transfer complete.

    COMMAND:> PASV

    227 Entering Passive Mode (xx,xx,171,79,5,59)

    COMMAND:> LIST

    STATUS:> Connecting FTP data socket xx.xx.171.79:1339…

    150 Opening data connection

    226 Transfer complete

    greetings, renke

    #32478
    Anonymous
    Participant

    Some people reported that DL with CuteFTP works.

    I am using WS_FTPLE and I get the same error problem…

    DL fails and I get 0KB file on my folder.

    Did not have this problem when I upgrded to ver.2.11 Beta 2.

    Is it problem with ver.2.22 or did I miss to change some settings?

    #32479
    spaltd
    Participant

    I’m having the same problem, only I can’t even get downloads with an FTP client.

    I can download files with IE, but they’re all 0kb.

    you guys get anywhere with this yet?

    #32480
    spaltd
    Participant

    turns out my problem was due to the Optimize File Sending in the Server Manager >> Advanced section.

    unchecked this and everything works fine now.

    hope this helps.

    #32481
    Anonymous
    Participant

    I can confirm this problem, I’ve got Cerberus running on my win 98 lappy on the red side of my firewall with a portfoward to it.

    When connecting wth WSFTP PRO & LE upload A-ok download 0byte fail.

    Again if you deselect the use optimized file sending in the advanced section this fixes the problem.

    Might be worth on future versions to have this deselected by default and turn it on as an option.

    Though I supose people don’t support 98 anymore so anything above should be fine.

    #32482
    spaltd
    Participant

    well, just to clarify, my setup was on NT 4.0 and access problems were from W2k Pro.

    haven’t had a chance to read up yet on the optimized file send feature, so I’m not really sure what’s it for.

    #32483
    Anonymous
    Participant

    removing optimized file sending:

    it works like a charm!!

    Even though it’s ‘for NT’ it does make a difference (running win98se).

    Thanks a lot, I had really given it up!

    #32484
    Anonymous
    Participant

    spaltd wrote:

    turns out my problem was due to the Optimize File Sending in the Server Manager >> Advanced section.

    unchecked this and everything works fine now.

    hope this helps.

    true, thanks a lot

Viewing 15 posts - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.
Close Cart

Shopping Cart