Could not connect after upgrading to 4.0

Home Forums General Report a Bug Could not connect after upgrading to 4.0

  • This topic is empty.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #30001
    Madgex
    Participant

    Hello,

    I’ve been running Cerberus 3.1.4 64Bit for a while now without any problems. I run on Windows 2003 64Bit SP2. Last night I upgraded to 4.0 using the built in update process, stopping the windows service beforehand because I’ve had crashes in the past when trying to update with it started.

    Cerberus came back up. I immediately noticed one of the IPs that was whitelisted was now getting blocked. I saw this straight away because it’s an IP that monitors whether the server is up or not, so it polls the cerberus every few minutes on port 21. I re-added the IP into the IP Manager and that was then fine.

    I then tested whether I could connect using FTPS… no go. I got an error in the Cerberus log saying something along the lines of “Unable to connect passive port”, I forget what the error was exactly but it was definitely saying the passive ports were not working in some way. I tried regular unsecure FTP and got the same error.

    I had a look through the Cerberus settings and everything was as it should be, nothing had changed during the upgrade process. I could not see why the FTP was no longer working. I restarted the service but still nothing could connect.

    So I uninstalled 4.0, downloaded 3.1.4 again and reinstalled it. All is now back to normal.

    Hopefully someone can tell me what happened, I would like to upgrade if possible.

    Thanks,

    Russ

    #35690
    Madgex
    Participant

    I’ve looked through the logs and the exact error was:

    Unable to accept passive connection

    For help see http://www.cerberusftp.com/faq/initialsetup.htm#Q3

    425 Unable to open the data connection

    I’d like to stress that before the update, and of course now since rolling back to 3.1.4, there were no issues with accepting passive connections. I have a range of ports specified in Cerberus which are also open inbound on my firewall.

    Regards,

    Russ

    #35691
    imported_Serin
    Participant

    Thanks for the report Russ. Can you send me (support@cerberusftp.com) or post a complete log file from 4.0 so I can see a sequence of events?

    My first thought is that this might be a firewall problem with not recognizing the new CerberusGUI.exe. The old version is still recognized by the firewall. It’s just a guess. Are you running any sort of firewall software?

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.
Close Cart

Shopping Cart