Crashes after enabling SSL/TLS

Home Forums General Report a Bug Crashes after enabling SSL/TLS

  • This topic is empty.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #30060
    ABCFTP
    Participant

    Hello – upgraded from 4.0.3.3 (i think) to 4.0.5.2 this morning. We needed to support Public Key authentication for SFTP transfers as added in v 4.0.4.0.

    However, now everytime I go into server settings and enable SSL/TLS the application crashes.

    #35902
    imported_Serin
    Participant

    Hello,

    That is strange, I can’t seem to duplicate the problem. You are referring to the “Enable TLS/SSL” option on the Security tab, right?

    I have a few questions to try to diagnose or duplicate what is going on:

    What kind of SSL certificate are you using? Was it created using the the built-in self-sign certificate wizard? A certificate from somewhere else?

    Are you running Cerberus FTP Server Professional?

    Also, why did you need to enable SSL/TLS on the Security tab after upgrading? You would have needed to have TLS/SSL enabled to initiate SSL or SFTP connections in previous versions too.

    Finally, can you post a log file from Cerberus showing the last entries before the crash?

    #35903
    ABCFTP
    Participant

    Serin wrote:

    Hello,

    That is strange, I can’t seem to duplicate the problem. You are referring to the “Enable TLS/SSL” option on the Security tab, right?

    I have a few questions to try to diagnose or duplicate what is going on:

    What kind of SSL certificate are you using? Was it created using the the built-in self-sign certificate wizard? A certificate from somewhere else?

    Are you running Cerberus FTP Server Professional?

    Also, why did you need to enable SSL/TLS on the Security tab after upgrading? You would have needed to have TLS/SSL enabled to initiate SSL or SFTP connections in previous versions too.

    Finally, can you post a log file from Cerberus showing the last entries before the crash?

    Yes

    Built-in self-signed (I even re-created a new one after upgrade thinking it might help)

    Yes

    There may have been a bug here – I had it unchecked. I checked it, setup a self signed cert and then realized we didn’t need one for SFTP. So I unchecked it, and SFTP continued to work OK.

    Code:

    [2010-09-15 09:04:09]: SYSTEM [server] – Intel(R) Xeon(TM) CPU 3.20GHz with 2 processors
    [2010-09-15 09:04:09]: SYSTEM [server] – Microsoft Windows Server 2003 “R2” Standard x64 Edition
    [2010-09-15 09:04:09]: SYSTEM [server] –
    [2010-09-15 09:04:09]: SYSTEM [server] – Cerberus FTP Server 4.0.5.2 – Professional started on ‘PARK-B2B-01’
    [2010-09-15 09:04:09]: SYSTEM [server] – Installed as a Windows Service but started in application mode
    [2010-09-15 09:04:09]: SYSTEM [server] –
    [2010-09-15 09:04:09]: SYSTEM [server] – Cerberus added to Windows Firewall Exception list
    [2010-09-15 09:04:09]: SYSTEM [server] –
    [2010-09-15 09:04:09]: SYSTEM [server] – Interface 0 (FTP) listening at 192.168.2.14 on port 21
    [2010-09-15 09:04:10]: SYSTEM [server] – Interface 2 (SFTP) listening at 192.168.2.14 on port 22
    [2010-09-15 09:04:13]: SYSTEM [server] – WAN IP detected as xxx.xxx.xxx.xxx
    [2010-09-15 09:04:57]: SYSTEM [server] – TLS/SSL support ready – ‘RSA’ keys loaded
    [2010-09-15 09:04:57]: SYSTEM [server] –
    [2010-09-15 09:05:40]: SYSTEM [server] – Intel(R) Xeon(TM) CPU 3.20GHz with 2 processors
    [2010-09-15 09:05:40]: SYSTEM [server] – Microsoft Windows Server 2003 “R2” Standard x64 Edition
    [2010-09-15 09:05:40]: SYSTEM [server] –
    [2010-09-15 09:05:40]: SYSTEM [server] – Cerberus FTP Server 4.0.5.2 – Professional started on ‘PARK-B2B-01’
    [2010-09-15 09:05:40]: SYSTEM [server] – Installed and started as a Windows Service
    [2010-09-15 09:05:40]: SYSTEM [server] –
    [2010-09-15 09:05:40]: SYSTEM [server] – Cerberus added to Windows Firewall Exception list
    [2010-09-15 09:05:40]: SYSTEM [server] –
    [2010-09-15 09:05:43]: SYSTEM [server] – WAN IP detected as xxx.xxx.xxx.xxx
    [2010-09-15 09:05:45]:CONNECT [server] – Client connected to Cerberus FTP Server 4.0.5.2 on ‘PARK-B2B-01’
    [2010-09-15 09:05:45]: INFO [server] –

    Also, here’s what happens if I try to connect via SFTP without checking the SSL/TLS box. I thought this might be useful since the log indicates SSL/TLS support is enabled.

    Code:

    [2010-09-15 09:13:38]:CONNECT [ 0] – Incoming connection request on interface 2 at 192.168.2.14
    [2010-09-15 09:13:38]:CONNECT [ 0] – SSH FTP Connection request accepted from 192.168.2.194
    [2010-09-15 09:13:38]: ERROR [ 0] – Key Exchange Algorithm Negotiation Failure: Ignoring next message
    [2010-09-15 09:13:38]:SUGGEST [ 0] – You must enable TLS/SSL from the Security page of the Server Manager and ensure a key pair is available to establish SFTP and FTPS connections
    [2010-09-15 09:13:38]: INFO [ 0] – Ignoring packet
    [2010-09-15 09:13:58]:CONNECT [ 0] – Closing connection: An existing connection was forcibly closed by the remote host.

    [2010-09-15 09:13:58]:CONNECT [ 0] – Connection terminated

    #35904
    imported_Serin
    Participant

    A few more questions:

    When, exactly, does the crash occur? Is it after pressing the “Ok” button on the server manager after checking the “TLS/SSL Enabled” checkbox? Does the service crash, or just the UI window?

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.
Close Cart

Shopping Cart