directory listing bug.

Home Forums General Report a Bug directory listing bug.

  • This topic is empty.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #28669
    Anonymous
    Participant

    i just upgraded to the newest version 2.22. i upgraded from something a bit further back.. not 2.21 or whatever… something i downloaded 6 months ago or more.

    when i upgraded i kept all the settings from the old version and everything looked just fine. seemed like it would work exactly the same as the old version…. but this of course didnt happent thats why i am reporting this bug.

    i basically only had 2 user accounts, no anonymous accounts… basically only one of the accounts is used, the other was just for a one time thing needed to give a freind a file so i setup another account.

    with the main account that i use this server for, i have it set up so that the account can access nearly all my files. i add all the drives to the root, other than the C drive, then i give access to one folder on the C drive and allow all access in that folder…

    so basically i have the account setup like this:

    path renamed to show as permisions

    D: Drive-D download

    E: Drive-E download

    F: Drive-F download

    G: Drive-G download

    H: Drive-H download

    C:Private Private All allowed.

    this worked just fine on the older version (2.15 or 2.16) but when i upgraded to the new version (2.22) when logging in and getting

    the list of root…. only Drive-D , Drive-E, and private would show.

    In the log window i would get three errors saying something about

    “error sending a root directory” but on the same line it would say something about completing successfully. hehe sorry i didnt copy down the entire message but it started with the “error sending a root directory” part.

    i thought perhaps there was an incompatibility with how the old and new servers stored the account data so i removed the accounts, and readded this one… set it back up the same and had the same problem

    then i decided that perhaps it was just showing 3 on the list, so i deleted the drive-d and drive-e entries and still it wouldnt show F, G, or H so finally after even more tweaking and playing around… i decided that there must be some problem here… some bug… so i checked the permission for Display Hidden on Drive-G

    now when logging in Drive-G is liseted… but the other drives (F & H) werent so i checked the permission for those as well… and for good measure i added back the D and E drives… and checked it for them as well…. so now it works and shows all the diretories it should have been showing all along…. as well as any hidden files too i assume.

    I dont see how the server is seeing 3 of my drives as flagged to be hidden, while the other two are not flagged as hidden… basically its very odd, the D E and F partitions are all on the same drive, formated the same way.. with the exception of the files on them they are basically identical yet 1 is hidden?

    there must be some kind of bug in the server, introduced into it after 2.15 or 2.16 that causes this behaviour. there is no other explanantion that i can think up that would cause this other than a plain old bug. For now i have a workaround, although its not the best possible solution.

    thanks

    ๐Ÿ™„

    #32720
    imported_Serin
    Participant

    Hello,

    Thanks, I will look into the problem.

    #32721
    Anonymous
    Participant

    I All :)

    before worked just fine on the older version (2.16)

    now with upg (2.22)

    I dont see root directory!!!! (Lost all except one)..bug????

    or I miss something???

    for now I return old version….:(

    #32722
    imported_Serin
    Participant

    Ah, I’ve discovered and fixed the problem. The next release won’t have this problem. A temporary solution is to enable “Display Hidden folder” for each drive.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.
Close Cart

Shopping Cart