"Display hidden files = FALSE" doesn’t work

Home Forums General Report a Bug "Display hidden files = FALSE" doesn’t work

  • This topic is empty.
Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #28474
    Tuxman
    Participant

    Hi,

    on my CerberusFTP I activated the “anonymous” login with some shared folders, but I have NOT checked the option “Display hidden files” on every folder. Nevertheless, everyone can download from hidden subdirectories.

    Why? 😯

    #32340
    imported_Serin
    Participant

    Hidding a file does not restrict someone from downloading it if they know it is there. It simply prevents the directory or file from being sent in a list command.

    #32341
    Tuxman
    Participant

    Maybe, but they are “cryptic” filenames that no-one should know. :)

    I don’t believe that they could get the filenames from memory… :)

    #32342
    methos
    Participant

    Hello, I am using cftp server v4.0.2.2. I have setup a user account in simpe mode and have the ‘display hidden’ option unchecked (deny). Still hidden files and directories are listed with all the other directies and files. Any idea how to fix this?

    #32343
    imported_Serin
    Participant

    Hello,

    I’ll check into the problem and see if there is a bug.

    #32344
    imported_Serin
    Participant

    There is a bug in that the MLSD and MLST command results are not checked for hidden files. The LIST and NLST commands work as expected. I’ve fixed the problem and the next minor release will include the fix.

    Thanks,

    #32345
    loadme
    Participant

    In the meantime is there a way to switch to the old LIST command?

    We would love to use the hidden file function, too.

    It seems it uses MLSD and i couldn’t find an option to switch the listing commands.

    Something to force the client to use LIST instead of MLSD, until the update is out?

    From the first look and setup cerberus is a far superior ftp solution compared to others.

    The usability and clear interface are really great.

    And your well guiding htm-faq&help-pages really provide a good help for the first steps.

    #32346
    imported_Serin
    Participant

    Thanks for the positive comments on the product. We do strive to make the server easy to setup and intuitive to operate.

    There is no option to force LIST behavior in Cerberus – it is entirely a client function. However, we will probably be releasing the update with the fix tomorrow. I can provide a BETA release tonight if you need the fix immediately.

    #32347
    loadme
    Participant

    You sir are the best feature of this ftp server ;-)

    Thanks for the option, but tomorrow is more than fine.

    #32348
    loadme
    Participant

    hello.

    could you provide the patch including this fix ?

    thank you very much

    #32349
    imported_Serin
    Participant

    Hello,

    If you can’t wait for the official release then you can download the BETA from

    http://www.cerberusftp.com/files/CerberusInstallBeta.exe” class=”bbcode_url”>http://www.cerberusftp.com/files/CerberusInstallBeta.exe

    The BETA includes the fix and is probably going to be the same as the release version.

    #32350
    loadme
    Participant

    thank you for the fix

    i tested it and it works superb

    #32351
    methos
    Participant

    Thanks also, works great now!

Viewing 13 posts - 1 through 13 (of 13 total)
  • The topic ‘"Display hidden files = FALSE" doesn’t work’ is closed to new replies.
Close Cart

Shopping Cart