Error, SFTP: Unknown recipient channel: 0

Home Forums General FTP Client Help Error, SFTP: Unknown recipient channel: 0

  • This topic is empty.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #30172
    vendorIT
    Participant

    Hey there. Am trying to get BizTalk running the /n software SFTP adapter to connect to Cerberus 4.0.9.8 running SFTP, but am getting an ‘Unknown recipient channel: 0’ error when BizTalk trys to connect to the server. Below are the logs from Cerberus.

    Can someone please confirm if this is a problem with the SFTP server or client? Any help would be much appreciated.

    2011/10/05 16:23:58 [22] Incoming connection request on SSH interface 2 at 10.x.x.x

    2011/10/05 16:23:58 [22] SSH FTP connection request accepted from 10.x.x.x

    2011/10/05 16:23:58 [22] Algorithm negotiation complete: Proceeding with key exchange

    2011/10/05 16:23:58 [22] Kex: ‘diffie-hellman-group1-sha1’ Host Key: ‘ssh-rsa’ C2S : ‘3des-cbc, hmac-sha1, none’ S2C : ‘3des-cbc, hmac-sha1, none’

    2011/10/05 16:23:59 [22] DH Key sizes: Server Public ‘1023’, Private ‘1023’, Client Public ‘1017’

    2011/10/05 16:24:01 [22] Authenticating password for user ‘test’

    2011/10/05 16:24:01 [22] Native user ‘test’ authenticated

    2011/10/05 16:24:01 [22] Channel Open: ‘session’, Sender Channel: 0, Init Window Size: 1048576, Max Packet Size: 524288

    2011/10/05 16:24:01 [22] Creating local channel: 336

    2011/10/05 16:24:01 [22] Channel Request: ‘subsystem’, Recipient Channel: 0, Subsystem Name: ‘sftp’, Reply: true

    2011/10/05 16:24:01 [22] Unknown recipient channel: 0

    2011/10/05 16:24:58 [22] The client closed the connection

    2011/10/05 16:24:58 [22] Connection terminated

    #36252
    imported_Serin
    Participant

    Hello,

    I already answered this via email but I thought I would post the result to the forum also:

    It looks like a bug in the BizTalk SFTP adapter. The SFTP client is requesting to open an SFTP channel but is requesting it on the wrong recipient channel. It looks like the client has the sender and recipient channel reversed. We’ve tested with dozens of other clients that do this correctly so it definitely appears to be a client bug. We always validate request parameters so the server is properly rejecting the request.

    Is there a newer version of the adapter you can use? Perhaps they’ve fixed this problem in a newer version.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.
Close Cart

Shopping Cart