FTP Connections & ZeBeDee

Home Forums General Firewall Help FTP Connections & ZeBeDee

  • This topic is empty.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #28002
    deroby
    Participant

    Although this is probably a ZeBeDee (http://www.winton.org.uk/zebedee/” class=”bbcode_url”>http://www.winton.org.uk/zebedee/) (ZBD from now on) issue, this is the first time the program fails me and I’m pretty sure there will be someone here who will be able to explain me what’s wrong, and it might help out others too :

    The situation :

    I’ve installed Cerberus v2.11 (CFS from now on) and added and enabled 127.0.0.1 to the interfaces. When I connect using TotalCommander or LeechFtp it tells me something like this :

    Incoming connection request on interface 127.0.0.1

    Connection request accepted from 127.0.0.1

    USER xyz

    PASS ***********

    SYST

    FEAT

    PWD

    TYPE A

    PASV

    Connection with data socket accepted

    LIST

    The data connection was closed by the remote socket

    So, all is well, the directory gets listed.

    When I now make a connection via ZBD (=> a remote computer logs on to the ZBD-server on port 19xxx, ZBD will ‘tunnel’ the connection to a local (127.0.0.1) connection and connects to CFS, apparantly that goes fine, however, once it reaches the LIST command an error occurs.

    Incoming connection request on interface 127.0.0.1

    Connection request accepted from 127.0.0.1

    USER xyz

    PASS ***********

    SYST

    FEAT

    PWD

    TYPE A

    PASV

    PORT 127,0,0,1,9,207

    LIST

    No connection could be made because the target machine actively refused it.

    QUIT

    The connection was closed by the remote socket.

    Connection terminated.

    From the other posts here I’m starting to understand that CFS tries to re-connect to the client (here ‘faked’ by ZBD) on port 20, unless specified differently by the PORT command.

    Since I understand this is rather hard to setup via ZBD, I switch on the PASV option in TotalCommander and now kind of expect CFS to ONLY use port 21 for all traffic. Is this naieve & impossible ? And if so, is there ANY way to have it like that ??

    PS: after rereading, I suddenly see that the PORT command only occurs in the ZBD connection, although I’m pretty sure BOTH Totalcommanders are the same version and they both have the same FTP Connection settings. Weird. Would ZBD ‘insert’ this command ?!? I’ll dig into it, in the mean time feel free to send me hints =)

    Thanks for your time,

    Roby

    #31152
    imported_Serin
    Participant

    Hello,

    The first thing I would check is that your firewall is allowing [outgoing] connections from port 20. One of the differences between using active FTP (the PORT command) vs. PASV FTP (the PASV command) is that with active FTP, the FTP server initiates the connection to the IP addess specified in the PORT command. With PASV ftp, the client is connecting to the server. Firewalls tend to be a little more forgiving of PASV mode FTP.

    One other thing to check, make sure “Deny FXP transfers” is turned off under the Advanced tab of the Server manager. There may be a bug that is preventing the PORT command from working in certain situations. Once confirmed, this will be corrected in version 2.12.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.
Close Cart

Shopping Cart