FTP Error – 425 Unable to open the data connection.

Home Forums General FTP Client Help FTP Error – 425 Unable to open the data connection.

  • This topic is empty.
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #30220
    renan_stig
    Participant

    Good morning,

    I’m trying to create a ftp server on my laptop.

    Whenever I try to connect using my local network, it works perfectly, but when I try do the same using an external connection I receive the following error:

    425 Unable to open the data connection.

    I’ve already tried to open the ports 21 and 20 of my router and still didn’t work.

    In the “Server Manager”, “PASV Port Range”, I’ve already put the correctly range that I use in my router.

    Here’s the log i’m receiving.

    2012/02/14 09:38:28 [45] QUIT

    2012/02/14 09:38:28 [45] Connection terminated

    2012/02/14 09:38:28 [46] The client closed the connection

    2012/02/14 09:38:28 [46] Connection terminated

    2012/02/14 09:39:53 [47] Incoming connection request on FTP interface 51 at 192.168.0.104

    2012/02/14 09:39:53 [47] FTP connection request accepted from 187.77.26.207

    2012/02/14 09:39:53 [47] USER Renan

    2012/02/14 09:39:53 [47] 331 User Renan, password please

    2012/02/14 09:39:53 [47] PASS ***********

    2012/02/14 09:39:53 [47] Native user ‘Renan’ authenticated

    2012/02/14 09:39:53 [47] 230 Password Ok, User logged in

    2012/02/14 09:39:53 [47] PWD

    2012/02/14 09:39:53 [47] 257 “/” is the current directory

    2012/02/14 09:39:54 [47] TYPE I

    2012/02/14 09:39:54 [47] 200 Type Binary

    2012/02/14 09:39:54 [47] MODE B

    2012/02/14 09:39:54 [47] 504 Mode B unsupported

    2012/02/14 09:39:54 [47] PASV

    2012/02/14 09:39:54 [47] 227 Entering Passive Mode (186,207,246,219,32,29)

    2012/02/14 09:39:54 [47] LIST

    2012/02/14 09:39:54 [48] Incoming connection request on FTP interface 51 at 192.168.0.104

    2012/02/14 09:39:54 [48] FTP connection request accepted from 187.77.26.207

    2012/02/14 09:41:25 [47] Timeout while waiting for connection

    2012/02/14 09:41:25 [47] Passive failure: For help see http://www.cerberusftp.com/support/faq/initialsetup.htm#Q3

    2012/02/14 09:41:25 [47] 425 Unable to open the data connection

    2012/02/14 09:41:25 [47] CWD /

    2012/02/14 09:41:25 [47] 250 Change directory ok

    2012/02/14 09:41:25 [47] LIST

    2012/02/14 09:41:25 [47] Socket error while waiting for connection: An operation was attempted on something that is not a socket.

    2012/02/14 09:41:25 [47] Passive failure: For help see http://www.cerberusftp.com/support/faq/initialsetup.htm#Q3

    Hope you guys can help me to solve the problem.

    #36393
    imported_Serin
    Participant

    Hello,

    See this link:

    http://www.cerberusftp.com/support/faq/initialsetup.htm#Q2

    You have to open the PASV port range too. If that still doesn’t work, then this should fix it:

    http://www.cerberusftp.com/support/faq/troubleshooting.html#Q3

    #36394
    renan_stig
    Participant

    Hi Serin,

    I’ve already done both of them but still didn’t work…

    I still can’t list the files =

    do you have more ideas?

    Thx

    #36395
    imported_Serin
    Participant

    Can you post the Cerberus log showing a connection attempt after changing the Interface to use the internal IP for passive? Are you sure you changed the correct IP, and not the Default FTP interface?

    #36396
    renan_stig
    Participant

    The message i received as return now was different.

    It says ” 227: Entering Passive Mode ( 192,168,0,104,32,29)

    as you can see I get the same message in CerberusLog:

    2012/02/15 01:47:40 [13] 227 Entering Passive Mode (192,168,0,104,32,29)

    2012/02/15 01:47:30 [13] Incoming connection request on FTP interface 27 at 192.168.0.104

    2012/02/15 01:47:30 [13] FTP connection request accepted from 187.77.78.218

    2012/02/15 01:47:38 [13] USER Renan

    2012/02/15 01:47:38 [13] 331 User Renan, password please

    2012/02/15 01:47:39 [13] PASS ***********

    2012/02/15 01:47:39 [13] Native user ‘Renan’ authenticated

    2012/02/15 01:47:39 [13] 230 Password Ok, User logged in

    2012/02/15 01:47:39 [13] PWD

    2012/02/15 01:47:39 [13] 257 “/” is the current directory

    2012/02/15 01:47:39 [13] TYPE I

    2012/02/15 01:47:39 [13] 200 Type Binary

    2012/02/15 01:47:39 [13] CWD ftproot/

    2012/02/15 01:47:39 [13] 250 Change directory ok

    2012/02/15 01:47:40 [13] MODE B

    2012/02/15 01:47:40 [13] 504 Mode B unsupported

    2012/02/15 01:47:40 [13] PASV

    2012/02/15 01:47:40 [13] 227 Entering Passive Mode (192,168,0,104,32,29)

    2012/02/15 01:47:40 [13] QUIT

    2012/02/15 01:47:40 [13] Connection terminated

    2012/02/15 01:48:51 [12] Timeout while waiting for connection

    2012/02/15 01:48:51 [12] Passive failure: For help see http://www.cerberusftp.com/support/faq/initialsetup.htm#Q3

    2012/02/15 01:48:51 [12] 425 Unable to open the data connection

    2012/02/15 01:48:51 [12] The client closed the connection

    2012/02/15 01:48:51 [12] Connection terminated

    #36397
    imported_Serin
    Participant

    What does your network setup look like? My guess is that the router wasn’t configured quite correctly to forward all of the ports, or that there is another device on the network that needs forwarding enabled. Have you also tried disabling any firewalls on your local PC to make sure that isn’t interfering? The local firewall can sometimes be the culprit.

    I would go back to using port forwarding as opposed to specifying a manual IP and using the internal IP for passive. Troubleshoot it from there.

    #36398
    renan_stig
    Participant

    I use a wireless connection and I have an DI-524 as router.

    Here you can see the configuration of cerberus:

    http://imageshack.us/photo/my-images/403/cerberusconfig.png/

    Here you can see the configuration of my router:

    http://imageshack.us/photo/my-images/189/routerconfig.png/

    I’m using an account on NO-IP.org in order to access my FTP from other network.

    I’ve already turned off my firewall and my kaspersky but still didn’t work.

    Now i can’t list the files in my ftp server

    Thx

    #36399
    imported_Serin
    Participant

    Hello,

    Your port forwarding setting look incorrect.

    You are telling your router to forward ports 8000 – 9000 to private port 21. I don’t think that makes sense.

    You should probably have two separate rules:

    Public port 21 to private port 21

    Public port range 8000 – 9000 to private port range 8000 – 9000

    If your wireless router and DSL router are the same device then that should do it. If your wireless router is a separate device then you probably also need to enable port forwarding there as well.

    #36400
    renan_stig
    Participant

    That makes sense.

    By default i can’t access port 21 directly from connections that isn’t local.

    That’s why i made that rule.

    If I put xxx.xxx.xxx.xxx:8000 on my ftp client. I’ll be port forwarded to 21.

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.
Close Cart

Shopping Cart