FTP wont go beyond my router

  • This topic is empty.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #29136
    ukdeveloper
    Participant

    Hi I have a BT Voyager 2100 Wireless Modem/Router connected through bulldog broadband (apparently no port blocking).

    When I try and connect through my LOCAL IP 192.168.1.4 to the cerberus server everything works fine, but when i try and connect through my WAN nothing seems to get past the router.

    This is the log i get from my ftp program

    Connecting to 87.74.24.20 , 21 Dec 2005 23:01:50

    < 220 Ftp firmware update utility > USER carl

    < 331 Password please. > PASS (hidden)

    < 421 Login incorrect. < 421 Login incorrect. Connection closed 421 Login incorrect. Im not sure what the ftp firmware update utility means either. I have tried this in both active and passive modes, neither work. My port forwarding is set up as below: Name:FTP Server IP Address: ALL Protocol: TCP Port: 21 Internal Host:192.168.1.4 Port:21 I have also set up the same for port 20 and have enabled access to ports 20 and 21 in my firewall (norton) and disabled windows firewall Any ideas? regards Carl

    #33633
    PahaN
    Participant

    Hi ukdeveloper , a have the same problem with my Voyager 220V to connect to internal FTP server, please let me know, if sort it out.

    #33634
    molk
    Participant

    @ ukdeveloper

    have no clue what ‘220 Ftp firmware update utility’ is but ‘421 Login incorrect’ could be that service is not correctly set up or wrong pass.

    What ftp client are you trying to use?

    It is the client with its request who specify what mode to use. But if the server settings is not not correctly done it will of course not work. The easiest mode to have working is the active mode. Allow port 21 in and port 20 out. Most routers and firewalls have that setting preconfigured, so to activate you only have to enable it by ticking the box at that rule in the router. And all corresponding settings in every submeny is done as soon as you told the local ip of the ftp computer.

    At other firewalls you have to set up ftp as a service at one setting and in another open up a port in the firewall and forward that traffic to the Cerberus computers local ip. Some brands are calling this virtual server and portforwarding.

    If using win xp sp2, the firewall is on by default and ftp have to be installed as a service in the settings. You also have specify the ports to open for incoming traffic. ( some ISP have blocked port 21 so you have to use none standard port)

    What is more tricky from server side aspect is the passive mode.

    Cerberus have a default portrange which have to also be set in the software firewall and/or router (if using both).

    The passive mode is very differently handled by the different router brands. A setting that works for one brand, have to be dealt with in another way having another model and/or brand.

    But in princip you have to configure ftp as a service in one setting, and at another menu open up corresponding portrange in firewall of router and portforward that range to the local ip for that Cerberuscomputer.

    Because of the portrange needed i do not recommend the inbuilt firewall in win xp.

    The portrange specified in Cerberus can be changed to something totally different. But do all changes everywhere: Cerberus, router, software firewall.

    #33635
    uk_user_44
    Participant

    Are you connecting to your router from your LAN? If so it assumes you are trying to update it’s firmware and port forwarding doesn’t work from the internal network.

    You can log in to it using your router admin account and password by the way!

    When you connect to it over the internet, if you have set up the port forwarding correctly it should pass ftp through to your Cerberus ftp server.

    Just been through this (with my 2100) so know what I’m talking about, just set up any LAN ftp clients to use the ftp server’s own IP address/name.

    Cheers

    Dave

Viewing 4 posts - 1 through 4 (of 4 total)
  • The topic ‘FTP wont go beyond my router’ is closed to new replies.