I can connect, but LIST command doesn’t work

Home Forums General FTP Client Help I can connect, but LIST command doesn’t work

  • This topic is empty.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #29170
    I301199
    Participant

    Hello. I have installed Cerberus FTP server on my computer.

    I can access to my ftp server from any computer inside my network but from the internet I can’t.

    I get connected to 8021 port. The connection seems to be established, but the files cannot be listed. I have tried with all options from cuteFTP client:

    – Use PASV

    – Use PORT

    – Use Global Settings

    The Cerberus FTP server log is the following. Can anybody helpme?

    Sun Jan 29 18:30:44 2006 Added to Windows Firewall Exception list

    Sun Jan 29 18:30:43 2006 Attempting to detect WAN IP…

    Sun Jan 29 18:30:43 2006 WAN IP detected as xx.xx.xxx.xx

    Sun Jan 29 18:30:44 2006 Vendor: GenuineIntel

    Sun Jan 29 18:30:44 2006 CPU: Intel

    Sun Jan 29 18:30:44 2006 Number of Processors: 1

    Sun Jan 29 18:30:44 2006 Operating System: Microsoft Windows XP Professional

    Sun Jan 29 18:30:44 2006 Additional Info: Service Pack 2 (Build 2600)

    Sun Jan 29 18:30:44 2006 Cerberus FTP Server started

    Sun Jan 29 18:30:44 2006 Local Host: mmo-pc

    Sun Jan 29 18:30:44 2006 Local Interface 0 located at 192.168.1.35

    Sun Jan 29 18:30:44 2006 Listening on Port 8021

    Sun Jan 29 18:31:24 2006 0 Incoming connection request on interface 192.168.1.35

    Sun Jan 29 18:31:24 2006 0 Connection request accepted from xx.xx.xxx.xx

    Sun Jan 29 18:31:24 2006 0 USER guest

    Sun Jan 29 18:31:24 2006 0 PASS ***********

    Sun Jan 29 18:31:25 2006 0 PWD

    Sun Jan 29 18:31:25 2006 0 FEAT

    Sun Jan 29 18:31:25 2006 0 REST 0

    Sun Jan 29 18:31:25 2006 0 PASV

    Sun Jan 29 18:31:25 2006 0 LIST

    #33710
    shuan4000
    Participant

    have you set PASV to the ip on the machine FTP is installed on, I had this problem and setting my PASV ip to my server ip worked, this may have been due to being on a network

    #33711
    doch83
    Participant

    One of the “fun” settings in FTP is the passive setting. Most of us know that somes sites won’t talk to you without it checked. However, others won’t talk to you if its checked.

    Turn off passive mode and see if that helps.

    To turn off passive mode in Windows:

    Open your Internet Options

    Go to the Advanced Tab

    Scroll almost to the end of the Browsing section and remove the check box from “Use Passtive FTP (for firewall and DSL modem compatibility)

    Hope that works,

    -Dave

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.
Close Cart

Shopping Cart