Timestamp bug? !

Think you've found a bug? Post a description here.

Moderator: Serin

Post Reply
intfan
Posts: 1
Joined: Mon Sep 04, 2006 2:11 am

Timestamp bug? !

Post by intfan » Mon Sep 04, 2006 2:29 am

Hi
I use cerberus ftp server version 2.3 (tried 2.4beta3, 2.21). I have some pictures I have taken on ftp server's folders. When I use client to list the folder, I found that many pictures time was modifed to 12:00am in my ftp client window and when I downloaded the file, the "Date modified" properties of the file was set to the 12:00am.

for example, I have a photo file "DSCN1623.JPG", on the original folder (when I first copy the image from CF card to my hard drive), it shows (right click the file name-> properties)
---------------
Created: Saturday, October 18, 2003, 12:18:02 AM
Modified: Sunday, May 11, 2003, 4:55:14 PM
---------------
When I list the directory under ftp server, this files show "5/11/2003 12:00AM".

After I download the file from ftp server, the transfered file has the following timestamp:
-------------------
Created: Sunday, May 11, 2003, 12:00:00 AM
Modified: Sunday, May 11, 2003, 12:00:00 AM
---------------------

I could use photoshop etc software to change the file timestamp according to EXIF data(OK under window explorer), but it is too tedious for thousands of pictures in hundreds of directories. Further, if the timestamps-corrected file was again put under ftp, when I list it, it will again show the weird time stamp "5/11/2003 12:00AM".

When I copy and paste in windows explorer, the timestamp is consistent with the original one.

I just get so confused.... is this a bug from windows or from ftp server?
Thanks!

acanthis
Posts: 1
Joined: Sun Oct 22, 2006 3:38 am

Post by acanthis » Sun Oct 22, 2006 3:45 am

I think the cause of the problem is the MDTM command. I have noticed in the log that any requests to get the timestamp of a file fail with the error "Invalid path"

Here's an example (this was using SmartFTP as the client against Cerberus FTP Server 2.4):

Oct 22 06:30:18 57 200 Type Binary
Oct 22 06:30:19 57 SIZE Frame 1240.v01.jpg
Oct 22 06:30:19 57 213 191869
Oct 22 06:30:19 57 MDTM Frame 1240.v01.jpg
Oct 22 06:30:19 57 550 MDTM failed: Invalid path

User avatar
Serin
Site Administrator
Posts: 1785
Joined: Sat Jan 01, 2005 6:57 pm
Location: United States
Contact:

Post by Serin » Tue Nov 07, 2006 11:55 pm

Hello, the problem is that the format of the MDTM command is incorrect. The command should be MDTM <filename>.

Post Reply