PASV IP address entry not working in v2.43

Think you've found a bug? Post a description here.

Moderator: Serin

Post Reply
krisweir
User
Posts: 13
Joined: Fri Jun 04, 2004 5:19 am
Location: Glasgow, Scotland
Contact:

PASV IP address entry not working in v2.43

Post by krisweir » Fri Mar 23, 2007 5:49 am

With v2.43 when you look at the server manager and interfaces, and PASV options, when "Use a different IP address for PASV command" is chosen, it no longer displays or accepts an IP address. Previously, the window would display 0.0.0.0 which you could overwrite - and tab between the decimals. Now there's nothing there, just a blank. (It doesn't matter if the new "don't use external IP for local connections" is ticked or not.)

You can type in an IP address, but when you "OK" out it's gone, and is not written to the registry when the program is shut down. Luckily my previous PASVIp:REG_DWORD entry is still in the registry, and PASV still appears to work.

Also, when the server accepts a PASV connection now, it displays in the log:

[2007-03-20 13:42:47]:COMMAND [3] - PASV
[2007-03-20 13:42:47]:REPLY [3] - 227 Entering Passive Mode (10,4,3,1,6,64)

Where 10.4.3.1 is obviously the internal address of the FTP server. Previously, when entering passive mode, it would display (e.g.)

[2007-03-12 15:09:30]:COMMAND [41] - PASV
[2007-03-12 15:09:30]:REPLY [41] - 227 Entering Passive Mode (k,l,m,n,6,173)

where k.l.m.n is the correct external IP address of the router. (This was what alerted me to the fact that something odd was going on with PASV IP.)

krisweir
User
Posts: 13
Joined: Fri Jun 04, 2004 5:19 am
Location: Glasgow, Scotland
Contact:

Working now.

Post by krisweir » Tue Mar 27, 2007 10:03 am

After some email support from Grant, I changed the PASV IP to auto-detect. This worked. Now, even when I go back to manual PASV IP, I can input IP addresses and they are saved correctly to the registry on shutdown (new key with dotted-decimal format, not the old hex one.)

There must be some transition error in the upgrade path. Hopefully v2.44 wil resolve this!

Post Reply