New Version: Some ip's already stored @ list?

Think you've found a bug? Post a description here.

Moderator: Serin

Post Reply
New User
Posts: 5
Joined: Sun Mar 25, 2007 8:59 am
Location: Winterswijk, Netherlands

New Version: Some ip's already stored @ list?

Post by DarkElement » Wed Mar 28, 2007 9:40 am

I downloaded the new version, which was released yesterday.
Now that i installed it, i see that in the IP-menu, there are already some ip's filled in.

I think this was for testing?

Btw, the problem is solved now, great work :D

User avatar
Site Administrator
Posts: 1785
Joined: Sat Jan 01, 2005 6:57 pm
Location: United States

Post by Serin » Wed Mar 28, 2007 10:07 am

No, was going to post a message about this.

If you were running Cerberus FTP Server 2.43, then the import can be incorrect. The IP block list was corrupted in version 2.43, and there is no simple way to determine or fix it. The importer to XML is essentially importing nonsense, though there is an expected file size check that tries to detect the corrupt file. If the bad file happens to be the correct size (probably what happened in your case), then the importer will import nonsense.

All versions prior to 2.43 should import fine (I hope). I've tried to test on several different versions, on several different platforms.

Post Reply