'Save Target As' Fails in IE 7 FTP Session for non-anonymous

Think you've found a bug? Post a description here.

Moderator: Serin

Post Reply
lev3
Posts: 1
Joined: Fri Jan 25, 2008 6:34 pm

'Save Target As' Fails in IE 7 FTP Session for non-anonymous

Post by lev3 » Sun Jan 27, 2008 12:20 pm

Using IE 7 for an FTP session:
1) Attempts to use nonymous login
2) Asserts login with every request

When logging in as a real user (non-anonymous), I am able to login, browse directory structures, and view file contents (e.g. test.txt) as much as I want; however, when I right click a file and select 'Save Target As' (STA), it fails.

The message in the Cerberus FTP Server log says:
530 Not logged in. Username/Password incorrect, user disabled, or user logged in too many times. While this message is seen repeatedly in the log durring the session, it does not stop the session from functioning.

Since 1 & 2 happen without causing the FTP server any problems with other requests, I don't see why the STA request causes it to fail.

Is there a way for the server to ignore the repeated login requests when talking to IE client sessions?

Also, is there a way to end a FTP sesion in IE without exiting IE; closing a sub window or tab does not seem to do the trick?

Thanks,
Lou

mdj
Moderator
Posts: 656
Joined: Mon Aug 18, 2003 4:00 am
Location: Denmark
Contact:

Post by mdj » Sun Jan 27, 2008 4:03 pm

You will have to post the entire log...

I don't know how to close a session in IE without terminating IE completely, but usually, there is a timeout on a FTP server of a minute or so, before inactive users are kicked off.
Morten Due Jørgensen
http://www.mdjnet.dk

knsesang
Posts: 1
Joined: Mon Mar 17, 2008 11:49 am

equal case.... login error

Post by knsesang » Mon Mar 17, 2008 11:55 am

Mar 18 00:52:39 33 Incoming connection request on interface 192.168.123.101
Mar 18 00:52:39 33 Connection request accepted from 221.142.57.244
Mar 18 00:52:39 33 USER anonymous
Mar 18 00:52:39 33 331 User anonymous, password please
Mar 18 00:52:39 33 PASS ***********
Mar 18 00:52:39 33 Logon failure: The user name did not belong to a valid NT user
Mar 18 00:52:43 33 530 Not logged in. Username/password incorrect, user disabled, or user logged in too many times
Mar 18 00:52:43 33 The connection was closed by the remote socket
Mar 18 00:52:43 33 Connection terminated.

Mar 18 00:52:43 34 Incoming connection request on interface 192.168.123.101
Mar 18 00:52:43 34 Connection request accepted from 221.142.57.244
Mar 18 00:52:43 34 USER anonymous
Mar 18 00:52:43 34 331 User anonymous, password please
Mar 18 00:52:43 34 PASS ***********
Mar 18 00:52:43 34 Logon failure: The user name did not belong to a valid NT user
Mar 18 00:52:47 34 530 Not logged in. Username/password incorrect, user disabled, or user logged in too many times
Mar 18 00:52:47 34 The connection was closed by the remote socket
Mar 18 00:52:47 34 Connection terminated.
[/img]

mdj
Moderator
Posts: 656
Joined: Mon Aug 18, 2003 4:00 am
Location: Denmark
Contact:

Post by mdj » Tue Mar 18, 2008 4:36 am

It sounds odd, that IE should log in using anonymous when you are otherwise logged in with a user. Then again, it is IE... Try using FileZilla or another intelligent client instead. There is no way to "ignore" it in the log, you could enable the anonymous user, and give it absolutely no rights, then perhaps you will just see normal logins in the log - unless IE is also trying to DO something with that user... But unless the anonymous user is indeed already enabled, it is definitely not a bug in Cerberus.
Morten Due Jørgensen
http://www.mdjnet.dk

jayjaya29
User
Posts: 12
Joined: Tue May 20, 2008 11:22 pm

Post by jayjaya29 » Wed Jul 09, 2008 12:01 pm

Sorry to bring up an older thread...better than making a new one.

I have the same problem with IE7. Firefox doesn't exhibit the same problem as IE7 with this issue thankfully.

Maybe a fix could be issued in the future?

t001z
New User
Posts: 3
Joined: Thu Jul 03, 2008 3:42 pm
Contact:

Post by t001z » Wed Jul 09, 2008 5:54 pm

We have noticed many bizarre actions in IE7 when it comes to FTP. Microsoft has all but made FTP a hidden feature in IE7... and unless I am mistaken, it is turned off by default:

(from MSDN forums)

1. Don't just type url into browser(IE7), it doesn't handle if the same as IE6. But do go into Tools-->InternetOptions-->Advanced: Check "Enable FTP folder view (outside of Internet Explorer)", located under "Browsing." Apply.

2. Create a new shortcut on your desktop. Enter "explorer ftp://yourDomainOrIP/", as the location of item. Name it whatever, "FTP to moms server."

3. Now click on the shortcut you just created, it should display what you were previously accustom to in ie6. Note: you may have to right click and select "Login as"

4. Go the extra mile by draging the shortcut into your Favorites so its easily accescible from IE.

Post Reply