ServerAliveInterval option on client ignored

Think you've found a bug? Post a description here.

Moderator: Serin

Post Reply
jdros
Posts: 1
Joined: Mon Jan 19, 2015 8:21 am

ServerAliveInterval option on client ignored

Post by jdros » Fri Jul 03, 2015 12:05 pm

Dear Sir/Madam

On SSH v2, there is this ServerAliveInterval option. Through which the client can bypass the "Idle Connection Timeout" server option, through dummy commands over the secure channel.

I am using the OpenSSH sftp command-line tool to connect to CerberusFTP, like:

Code: Select all

sftp -o 'ServerAliveInterval=15' ... 
However, the connection is dropped after the Server "Idle Connection Timeout" option.

Regards,
-jdros

User avatar
Serin
Site Administrator
Posts: 1785
Joined: Sat Jan 01, 2005 6:57 pm
Location: United States
Contact:

Re: ServerAliveInterval option on client ignored

Post by Serin » Sun Jul 05, 2015 12:00 pm

Hello,

This isn't a server bug. The server should be deciding when the connection is idle, not the client. If the server administrator would like to allow longer idle connection times then this setting can be changed on the server. In practice, a client can still perform a type of keep-alive by sending simple SSH commands on a regular basis.

This also doesn't appear to be part of the SSH2 standard. That setting apparently sends what they are calling an SSH null packet. There is no such concept in the SSH2 protocol. If they really want to perform a keep-alive at the SSH2 level then they should be sending dummy SSH2 or SFTP commands, like some clients do.

Post Reply