"Display hidden files = FALSE" doesn't work

Think you've found a bug? Post a description here.

Moderator: Serin

Locked
Tuxman
New User
Posts: 8
Joined: Mon May 10, 2004 9:25 pm
Location: Germany
Contact:

"Display hidden files = FALSE" doesn't work

Post by Tuxman » Fri Sep 24, 2004 1:09 pm

Hi,
on my CerberusFTP I activated the "anonymous" login with some shared folders, but I have NOT checked the option "Display hidden files" on every folder. Nevertheless, everyone can download from hidden subdirectories.
Why? :shock:
m00 ;)

User avatar
Serin
Site Administrator
Posts: 1785
Joined: Sat Jan 01, 2005 6:57 pm
Location: United States
Contact:

Post by Serin » Tue Oct 05, 2004 11:27 pm

Hidding a file does not restrict someone from downloading it if they know it is there. It simply prevents the directory or file from being sent in a list command.

Tuxman
New User
Posts: 8
Joined: Mon May 10, 2004 9:25 pm
Location: Germany
Contact:

Post by Tuxman » Thu Oct 07, 2004 1:54 am

Maybe, but they are "cryptic" filenames that no-one should know. :)
I don't believe that they could get the filenames from memory... :)
m00 ;)

methos
Posts: 2
Joined: Sat Jun 26, 2010 4:31 am

Re: "Display hidden files = FALSE" doesn't work

Post by methos » Sat Jun 26, 2010 4:46 am

Hello, I am using cftp server v4.0.2.2. I have setup a user account in simpe mode and have the 'display hidden' option unchecked (deny). Still hidden files and directories are listed with all the other directies and files. Any idea how to fix this?

User avatar
Serin
Site Administrator
Posts: 1785
Joined: Sat Jan 01, 2005 6:57 pm
Location: United States
Contact:

Re: "Display hidden files = FALSE" doesn't work

Post by Serin » Sun Jun 27, 2010 5:30 am

Hello,

I'll check into the problem and see if there is a bug.

User avatar
Serin
Site Administrator
Posts: 1785
Joined: Sat Jan 01, 2005 6:57 pm
Location: United States
Contact:

Re: "Display hidden files = FALSE" doesn't work

Post by Serin » Sun Jun 27, 2010 6:00 am

There is a bug in that the MLSD and MLST command results are not checked for hidden files. The LIST and NLST commands work as expected. I've fixed the problem and the next minor release will include the fix.

Thanks,

loadme
User
Posts: 25
Joined: Mon Jun 28, 2010 12:24 pm

Re: "Display hidden files = FALSE" doesn't work

Post by loadme » Mon Jun 28, 2010 5:26 pm

In the meantime is there a way to switch to the old LIST command?
We would love to use the hidden file function, too.

It seems it uses MLSD and i couldn't find an option to switch the listing commands.
Something to force the client to use LIST instead of MLSD, until the update is out?

From the first look and setup cerberus is a far superior ftp solution compared to others.
The usability and clear interface are really great.
And your well guiding htm-faq&help-pages really provide a good help for the first steps.

User avatar
Serin
Site Administrator
Posts: 1785
Joined: Sat Jan 01, 2005 6:57 pm
Location: United States
Contact:

Re: "Display hidden files = FALSE" doesn't work

Post by Serin » Mon Jun 28, 2010 6:08 pm

Thanks for the positive comments on the product. We do strive to make the server easy to setup and intuitive to operate.

There is no option to force LIST behavior in Cerberus - it is entirely a client function. However, we will probably be releasing the update with the fix tomorrow. I can provide a BETA release tonight if you need the fix immediately.

loadme
User
Posts: 25
Joined: Mon Jun 28, 2010 12:24 pm

Re: "Display hidden files = FALSE" doesn't work

Post by loadme » Mon Jun 28, 2010 7:06 pm

You sir are the best feature of this ftp server ;-)
Thanks for the option, but tomorrow is more than fine.

loadme
User
Posts: 25
Joined: Mon Jun 28, 2010 12:24 pm

Re: "Display hidden files = FALSE" doesn't work

Post by loadme » Tue Jun 29, 2010 8:47 pm

hello.

could you provide the patch including this fix ?


thank you very much

User avatar
Serin
Site Administrator
Posts: 1785
Joined: Sat Jan 01, 2005 6:57 pm
Location: United States
Contact:

Re: "Display hidden files = FALSE" doesn't work

Post by Serin » Tue Jun 29, 2010 9:07 pm

Hello,

If you can't wait for the official release then you can download the BETA from

http://www.cerberusftp.com/files/Cerber ... llBeta.exe

The BETA includes the fix and is probably going to be the same as the release version.

loadme
User
Posts: 25
Joined: Mon Jun 28, 2010 12:24 pm

Re: "Display hidden files = FALSE" doesn't work

Post by loadme » Wed Jun 30, 2010 6:59 pm

thank you for the fix
i tested it and it works superb

methos
Posts: 2
Joined: Sat Jun 26, 2010 4:31 am

Re: "Display hidden files = FALSE" doesn't work

Post by methos » Sun Jul 04, 2010 7:42 am

Thanks also, works great now!

Locked