qwerty / azerty compatibility issues

Think you've found a bug? Post a description here.

Moderator: Serin

Post Reply
iobeid

qwerty / azerty compatibility issues

Post by iobeid » Mon Feb 07, 2005 6:40 am

I'm running the Cerberus server on my windows xp machine - My OS is the french language version, although I'm using a qwerty keyboard and i've got my keyboard settings for the OS set to English. Cerberus screws up when I use any of the following letters in a password: a, m, q, z, w - all the letters which are not in common between qwerty and azerty keyboards. It lets me create the password, but then when you try to log in and type that password, it doesn't work. Any ideas? Thanks.

User avatar
Serin
Site Administrator
Posts: 1785
Joined: Sat Jan 01, 2005 6:57 pm
Location: United States
Contact:

Post by Serin » Thu Feb 10, 2005 8:34 pm

Are you absolutely certain that you are typing in the password correctly? Have you experimented with this at all, or is it just that the password no longer seems to be accepted? Have you tried reseting the password?

Thanks,

Guest

Post by Guest » Fri Feb 11, 2005 6:39 am

Yes, I am 100% certain this is actually happening. I just messed with it again and found something new. Lets say I want to use the password "apple". If I go to the user management and change the password by typing "apple", then I am unable to log in with that username and password. But lets say instead that I first open up a notepad window, type in the word "apple", and then copy and paste it into the password window in cerberus, then it works fine - I am able to log in with password "apple".

Definately odd, eh?

mdj
Moderator
Posts: 656
Joined: Mon Aug 18, 2003 4:00 am
Location: Denmark
Contact:

Post by mdj » Fri Feb 11, 2005 10:07 am

Setting the password "apple" using the keyboard, can you then log in using "qpple" - or whatever the right "translation" would be?
Morten Due Jørgensen
http://www.mdjnet.dk

User avatar
Serin
Site Administrator
Posts: 1785
Joined: Sat Jan 01, 2005 6:57 pm
Location: United States
Contact:

Post by Serin » Tue Feb 15, 2005 9:39 am

Hmm, at least that gives me something to look at. I'll check into it and get back to you.

iobeid

Post by iobeid » Fri Feb 18, 2005 4:08 am

Yes, if i set the password to "apple" and then log in with password "qpple", it works fine.

I've discovered something else - if I create a new user account, when I type in the user's name, the program uses the azerty keyboard settings even though my system is all set up to work with qwerty. For example, if I type in username "adam", the letters "qdq," appear on the screen.

Just to verify for your benefit - I'm using a qwerty keyboard on a machine that is running the french OS version of win xp. I've set the keyboard settings to "English / US" so that when I type on my qwerty keyboard, i get the corresponding letters on my screen. well, except for with cerberus.

Thanks.

Post Reply