need help

Anything you want!
Locked
blade
Posts: 1
Joined: Tue Oct 31, 2006 5:49 am

need help

Post by blade » Tue Oct 31, 2006 6:43 am

well i'm using ftp server that is installed of my personal computer
the operating system is win xp por sp2
also i have notron antivirus 2006
my firewall is off
all the settings is correct
& i have a php code that is using to upload files via ftp
the code works when i run it from this computer, but if the run run from another ps it will log in succesfull & change the dir but when it reach to command frp_put it will terminate the session, also if i try to connect via a window "like ftp://username:password@my-ip/" it sais timeout, here is the log

Code: Select all

Oct 31 13:29:34    Attempting to detect WAN IP...
Oct 31 13:29:34 WAN IP detected as 0.0.0.0

Oct 31 13:29:34 TLS/SSL support initialized
Oct 31 13:29:34 Added to Windows Firewall Exception list

Oct 31 13:29:34 Vendor: GenuineIntel
Oct 31 13:29:34 CPU: Intel Pentium IV
Oct 31 13:29:34 Number of Processors: 2
Oct 31 13:29:34 Operating System: Microsoft Windows XP Professional
Oct 31 13:29:34 Additional Info: Service Pack 2 (Build 2600)

Oct 31 13:29:34 Cerberus FTP Server started
Oct 31 13:29:34 Local Host: ranj1


Oct 31 13:29:34 Local Interface 1 located at 217.171.185.202
Oct 31 13:29:34 Listening on Port 21

Oct 31 14:00:06 Local Interface 2 located at 10.0.0.10
Oct 31 14:00:06 Listening on Port 21

Oct 31 14:01:43 0 Incoming connection request on interface 10.0.0.10
Oct 31 14:01:43 0 Connection request accepted from 10.0.0.10
Oct 31 14:01:43 0 USER test
Oct 31 14:01:43 0 331 User test, password please
Oct 31 14:01:43 0 PASS ***********
Oct 31 14:01:43 0 230 Password Ok, User logged in
Oct 31 14:01:43 0 CWD images/1
Oct 31 14:01:43 0 250 Change directory ok
Oct 31 14:01:43 0 PWD
Oct 31 14:01:43 0 257 "/images/1" is the current directory
Oct 31 14:01:43 0 TYPE I
Oct 31 14:01:43 0 200 Type Binary
Oct 31 14:01:43 0 PORT 10,0,0,10,6,97
Oct 31 14:01:43 0 200 Port command received
Oct 31 14:01:43 0 STOR 55023203.jpg
Oct 31 14:01:43 0 150 Opening data connection
Oct 31 14:01:43 0 File transfer complete
Oct 31 14:01:43 0 226 Transfer complete
Oct 31 14:01:43 0 The connection was closed by the remote socket
Oct 31 14:01:43 0 Connection terminated.
Oct 31 14:05:58 Shutting down local Interface 2 located at 10.0.0.10

Oct 31 14:07:02 Local Interface 3 located at 10.0.0.10
Oct 31 14:07:02 Listening on Port 21

Oct 31 14:08:06 Shutting down local Interface 3 located at 10.0.0.10

Oct 31 14:14:30 Local Interface 4 located at 10.0.0.10
Oct 31 14:14:30 Listening on Port 21

Oct 31 14:39:22 1 Incoming connection request on interface 10.0.0.10
Oct 31 14:39:22 1 Connection request accepted from 10.0.0.10
Oct 31 14:39:22 1 USER test
Oct 31 14:39:22 1 331 User test, password please
Oct 31 14:39:22 1 PASS ***********
Oct 31 14:39:22 1 230 Password Ok, User logged in
Oct 31 14:39:22 1 CWD images/1
Oct 31 14:39:22 1 250 Change directory ok
Oct 31 14:39:22 1 PWD
Oct 31 14:39:22 1 257 "/images/1" is the current directory
Oct 31 14:39:23 1 The connection was closed by the remote socket
Oct 31 14:39:23 1 Connection terminated.
kindly help me
thank you in advance
blade ;)

mdj
Moderator
Posts: 656
Joined: Mon Aug 18, 2003 4:00 am
Location: Denmark
Contact:

Post by mdj » Tue Oct 31, 2006 7:03 am

Probably router problems. However, this log does NOT say "timeout", as you mention, could you post a log, where you have logged on without the php-code?
Morten Due Jørgensen
http://www.mdjnet.dk

Locked