Page 1 of 2

can't send welcome message

Posted: Wed Oct 08, 2008 6:05 pm
by nose2000
:( my computer cant send welcome message - why

Posted: Thu Oct 09, 2008 3:33 am
by mdj
You need to post a log.

Posted: Thu Oct 09, 2008 5:35 pm
by nose2000
how do you post a log. O i got it

Posted: Thu Oct 09, 2008 5:46 pm
by nose2000
ct 07 16:23:35 Attempting to detect WAN IP...
Oct 07 16:23:35 WAN IP detected as 99.6.242.99

Oct 07 16:23:35 Added to Windows Firewall Exception list

Oct 07 16:23:35 System: Intel Pentium III
Oct 07 16:23:35 Number of Processors: 1
Oct 07 16:23:35 Operating System: Microsoft Windows XP Professional

Oct 07 16:23:35 Cerberus FTP Server started on 'main'


Oct 07 16:23:35 Interface 0 listening at 192.168.1.103 on port 21

Oct 07 16:24:19 0 Incoming connection request on interface 192.168.1.103
Oct 07 16:24:19 0 Connection request accepted from 192.168.1.101
Oct 07 16:24:20 0 Unable to send welcome message
Oct 07 16:24:20 0 Error: Unable to send Welcome message. Terminating connection.
Oct 07 16:24:20 0 Connection terminated.

Posted: Sat Oct 11, 2008 4:10 am
by mdj
Occassionally, or regularly? It could be simply "probes" from hacker tools testing if a FTP server is present, and terminating the connection immediately before Cerberus gets a chance to send the welcome message. The log shows that virtually no time passes from the connect to the error, so it is not a timeout. Perhaps Serin could put in some more loggings to clarify what happens? Serin?

Posted: Thu Feb 05, 2009 2:25 pm
by hscoggin
I see that this question never got answered. I'm having the same problem, and would love to get it resolved.

In addition, I have another really odd wrinkle along with it. This will take a bit to describe, so here goes:

I always have an "interface" listed with the IP address of my PC on my home network (currently 192.168.1.70). However, I've recently noticed that, when I plug in my Windows Mobile phone (AT&T 8525), another interface shows up with a completely different base address: currently 169.254.2.2. If I run IPCONFIG, or bring up the network connections in Windows, this shows up as "Local Area Connection 2."

When I try to connect to the FTP server via the IP address of my connection provided by my ISP, I get the "Unable to send welcome message" error. However, if I connect to the IP address that shows up when my phone is plugged in, I get connected successfully, and can access the authorized directories on my PC just fine.

Anyone got any ideas on either of these issues?

Posted: Tue Feb 17, 2009 6:07 pm
by Serin
I believe the "Unable to send welcome message" is almost always caused by a firewall blocking the connection. Adding Cerberus and the listening port to the firewall exception list always seems to fix this problem for people.

Newer beta version have somewhat better logging for this problem.

Posted: Wed Feb 18, 2009 11:09 pm
by hscoggin
Thanks for the response.

I added Cerberus to the firewall settings in my Trend Micro setup, and still get the same problem. I also upgraded to v2.49a of Cerberus, and that didn't help, either. I'll wait until the beta is a bit farther along before I try that.

Any other suggestions?

Re: can't send welcome message

Posted: Fri Apr 23, 2010 9:08 am
by hscoggin
Well, I found an inelegant, but effective way around the problem. I went to the Server Manager settings, then to the Messages tab, and blanked out the Welcome Message. Now I can connect with the server.

Sure wish someone would actually figure out the problem.

Re: can't send welcome message

Posted: Fri Apr 23, 2010 4:55 pm
by Serin
Hello hscoggin,

I really do think this is a problem with your environment. Something on your network is likely disconnecting the connection, whether it's a firewall, router, or the actual client. Only a few people ever report this issue and after investigation they always seem to find out it's a buggy router or firewall, or Internet security scanner interfering in some way. We've looked fairly closely at the code and we can't find any problems.

I'm definitely open to the idea that there might be a bug but the fact that only a small minority of people experience it and that they are usually able to find an external cause seems to indicate it isn't a bug. We simply haven't been able to reproduce it. The only reason you would get the error message you are reporting is if the connection was closed for some reason. That isn't something Cerberus would do unless you canceled the connection manually, or the client or a device on the network facilitating the connection closed the connection.

What might be happening is that you are sending a long welcome message and the send is occurring in multiple segments but the client is buggy and doesn't re-assemble the whole message. Thinking it's a message fragment, the client closes the connection. Sometimes the network might send the whole message in one send, sometimes it might break it up.

Re: can't send welcome message

Posted: Sun Apr 25, 2010 11:32 pm
by hscoggin
I don't doubt that it could be something in my settings, but I can't figure out what it could be. I'm using the latest version of Trend Micro Internet Security Pro, and I have Cerberus listed in the program control section, Incoming and outgoing, TCP protocol, all ports, all IP addresses. I also have FTP listed under the Network Protocol Control tab, incoming and outgoing, ports 20 and 21 on both, TCP protocol, all IP addresses.

Anything I'm overlooking?

Re: can't send welcome message

Posted: Sun Apr 25, 2010 11:59 pm
by Serin
Nothing obvious seems wrong. Is this happening with one FTP client in particular, or with several different types of FTP clients? Any obvious patterns to when it happens?

Something a little more radical...do you have another router you can try?

Re: can't send welcome message

Posted: Mon Apr 26, 2010 12:51 am
by hscoggin
It happens no matter what client I use, including just trying to connect using Internet Explorer. There's no pattern to it; it's absolutely consistent - never varies. However, I do get pretty frequent break-in attempts, and they don't generate this error. No idea what type of program is being used on the other end, of course.

I'm on AT&T U-Verse, so I'm tied to their router, short of some tedious exercises, but this has been going on since I was on Comcast with a D-Link router. I had two different ones that I tried at that time, and had the same problem with both.

Re: can't send welcome message

Posted: Mon Apr 26, 2010 1:00 am
by hscoggin
Well now, this is interesting. I just went back into the Server Manager, and put a Welcome message back in. It simply says, "Welcome!" I tried connecting, and voila! No error. I can't remember what the original, default welcome message was, or I'd put it back and try that. Now I'm wondering if there was some odd character in the original welcome message that was causing the problem.

Anyway, if anyone else is watching this thread, and having the same problem, try clearing out the welcome message and typing it back in. And post your results here. Now I'm really intrigued.

Re: can't send welcome message

Posted: Mon Apr 26, 2010 3:01 am
by Serin
That is interesting. The only thing I can think of related to the actual welcome message is if somehow a carriage return followed by a line feed was getting inserted into the welcome message. However, we do post processing on the message at various stages to make sure the message is correctly formatted.

Were you using a very long welcome message?