Trouble Configuring Trendnet Router

This forum is for anyone experiencing problems related to their firewall settings. More specifically, anyone experiecing connection issues should take a look at this forum.
Post Reply
bselin
New User
Posts: 3
Joined: Sun Dec 28, 2008 2:52 pm

Trouble Configuring Trendnet Router

Post by bselin » Sun Dec 28, 2008 5:20 pm

I am unable to configure my router to allow access to the Cerberus FTP server. I have a Trendnet TEW-452BRP router. The log from Cerberus is below:


Dec 28 14:57:51 Added to Windows Firewall Exception list

Dec 28 14:57:51 Shutting down local Interface 10 located at 192.168.1.100

Dec 28 14:57:51 System: Intel Pentium IV
Dec 28 14:57:51 Number of Processors: 2
Dec 28 14:57:51 Operating System: Microsoft Windows XP Home Edition

Dec 28 14:57:51 Cerberus FTP Server started on 'Brent'


Dec 28 14:57:51 Interface 11 listening at 192.168.1.100 on port 11000

Dec 28 14:58:03 12 Incoming connection request on interface 192.168.1.100
Dec 28 14:58:03 12 Connection request accepted from xx.xx.xx.xx
Dec 28 14:58:06 12 USER Henry
Dec 28 14:58:06 12 331 User Henry, password please
Dec 28 14:58:06 12 PASS ***********
Dec 28 14:58:06 12 230 Password Ok, User logged in
Dec 28 14:58:06 12 SYST
Dec 28 14:58:06 12 215 UNIX Type: L8
Dec 28 14:58:06 12 FEAT
Dec 28 14:58:06 12 211- Additional features supported include: MDTM SIZE REST STREAM AUTH TLS AUTH SSL PBSZ PROT LANG EN* SITE CHMOD SITE PSWD 211 End
Dec 28 14:58:06 12 PWD
Dec 28 14:58:06 12 257 "/" is the current directory
Dec 28 14:58:07 12 TYPE A
Dec 28 14:58:07 12 200 Type ASCII
Dec 28 14:58:07 12 PASV
Dec 28 14:58:07 12 227 Entering Passive Mode (xx,xx,xx,xx,43,2)
Dec 28 14:58:07 12 LIST
Dec 28 14:59:14 13 Incoming connection request on interface 192.168.1.100
Dec 28 14:59:14 13 Connection request accepted from xx.xx.xx.xx
Dec 28 14:59:15 13 USER Henry
Dec 28 14:59:15 13 331 User Henry, password please
Dec 28 14:59:15 13 PASS ***********
Dec 28 14:59:15 13 230 Password Ok, User logged in
Dec 28 14:59:15 13 SYST
Dec 28 14:59:15 13 215 UNIX Type: L8
Dec 28 14:59:15 13 FEAT
Dec 28 14:59:15 13 211- Additional features supported include: MDTM SIZE REST STREAM AUTH TLS AUTH SSL PBSZ PROT LANG EN* SITE CHMOD SITE PSWD 211 End
Dec 28 14:59:15 13 PWD
Dec 28 14:59:15 13 257 "/" is the current directory
Dec 28 14:59:16 13 TYPE A
Dec 28 14:59:16 13 200 Type ASCII
Dec 28 14:59:16 13 PASV
Dec 28 14:59:16 13 227 Entering Passive Mode (xx,xx,xx,xx,43,3)
Dec 28 14:59:16 13 LIST
Dec 28 14:59:38 12 Timeout while waiting for connection
Dec 28 14:59:38 12 Unable to accept passive connection
Dec 28 14:59:38 12 425 Unable to open the data connection
Dec 28 14:59:38 12 The connection was closed by the remote socket
Dec 28 14:59:38 12 Connection terminated.

I have added virtual servers to my router for ports 11000 and 10999. Not sure what I have setup in correctly. Any help appreciated.

mdj
Moderator
Posts: 656
Joined: Mon Aug 18, 2003 4:00 am
Location: Denmark
Contact:

Post by mdj » Mon Dec 29, 2008 3:19 am

You need to forward the passive port range too. Check out the FAQ, there is an entry there describing it.
Morten Due Jørgensen
http://www.mdjnet.dk

bselin
New User
Posts: 3
Joined: Sun Dec 28, 2008 2:52 pm

Post by bselin » Mon Dec 29, 2008 10:11 am

I have created a firewall rule on my router to allow TCP traffic on ports 10000 - 12000 but still receive the error. The port number that FileZilla is trying to reach is the same as the one that is registered in the log file. Any other ideas.

mdj
Moderator
Posts: 656
Joined: Mon Aug 18, 2003 4:00 am
Location: Denmark
Contact:

Post by mdj » Wed Dec 31, 2008 5:34 am

Then you should look at the ip address in the passive command. Is it the right external address of your router? Perhaps the router is "intelligent" and messes with the address? Is the right ip address shown in the FileZilla log?
Morten Due Jørgensen
http://www.mdjnet.dk

bselin
New User
Posts: 3
Joined: Sun Dec 28, 2008 2:52 pm

Post by bselin » Wed Dec 31, 2008 10:39 am

I finally was able to get it working. I had to change the PASV options for the interfaces to autodetect instead of using a different IP for the PASV option. Thanks for the help.

Post Reply