Profile load/save error in Vista 64-bit

Think you've found a bug in a BETA version of Cerberus FTP Server? Post a description here.
Locked
kburdic1
Posts: 2
Joined: Sat Jan 31, 2009 1:17 am

Profile load/save error in Vista 64-bit

Post by kburdic1 » Sat Jan 31, 2009 1:27 am

Brand new fresh install of the latest full version, downloaded today, 2.49a, on a Vista Home Premium SP1 64-bit system. Cerberus installs into the C:\Program Files (x86)\Cerberus directory.

Upon program start, the following error messages appear in the Cerberus log:

Profile Load Error
Unable to create Users file: access is denied
Stats file initialization error: Unable to open stats file

And when any changes are made to user accounts:

Profile Save Error
Unable to open Users file: access is denied

The user settings are only available for use as long as the program remains active. As soon as Cerberus is shut down, all user settings are lost because they were never really saved.

Solution?

mdj
Moderator
Posts: 656
Joined: Mon Aug 18, 2003 4:00 am
Location: Denmark
Contact:

Post by mdj » Mon Feb 02, 2009 4:13 am

Run the program as an administrator?
Morten Due Jørgensen
http://www.mdjnet.dk

kburdic1
Posts: 2
Joined: Sat Jan 31, 2009 1:17 am

Post by kburdic1 » Mon Feb 02, 2009 1:19 pm

Already did that. No difference. I ran the install routine as an administrator, and I run the program as administrator, absolutely nothing.

User avatar
Serin
Site Administrator
Posts: 1785
Joined: Sat Jan 01, 2005 6:57 pm
Location: United States
Contact:

Post by Serin » Tue Feb 17, 2009 5:59 pm

The only thing I can suggest is double-check that you are actually running as an administrator. The "Access denied" message is a pretty big indicator that the server can't write to the directory. Double check the permissions on the Cerberus install directory.

If you aren't looking for a production server, try upgrading to the 3.0.0 beta version. It works much better with Vista and shouldn't need to be run as an administrator.

Locked