Page 1 of 1

Profile load/save error in Vista 64-bit

Posted: Sat Jan 31, 2009 1:27 am
by kburdic1
Brand new fresh install of the latest full version, downloaded today, 2.49a, on a Vista Home Premium SP1 64-bit system. Cerberus installs into the C:\Program Files (x86)\Cerberus directory.

Upon program start, the following error messages appear in the Cerberus log:

Profile Load Error
Unable to create Users file: access is denied
Stats file initialization error: Unable to open stats file

And when any changes are made to user accounts:

Profile Save Error
Unable to open Users file: access is denied

The user settings are only available for use as long as the program remains active. As soon as Cerberus is shut down, all user settings are lost because they were never really saved.

Solution?

Posted: Mon Feb 02, 2009 4:13 am
by mdj
Run the program as an administrator?

Posted: Mon Feb 02, 2009 1:19 pm
by kburdic1
Already did that. No difference. I ran the install routine as an administrator, and I run the program as administrator, absolutely nothing.

Posted: Tue Feb 17, 2009 5:59 pm
by Serin
The only thing I can suggest is double-check that you are actually running as an administrator. The "Access denied" message is a pretty big indicator that the server can't write to the directory. Double check the permissions on the Cerberus install directory.

If you aren't looking for a production server, try upgrading to the 3.0.0 beta version. It works much better with Vista and shouldn't need to be run as an administrator.