Page 1 of 1

Can't use a different port other than 21

Posted: Sat Jun 27, 2009 6:36 am
by Henke81
Hi!
I want to set up my CFTPS to run at port 50 instead of the default port 21 but can't get it to work.
In the 'Interfaces'-settings, I have three different posts: default, 85.230.xxx.xxx (my current IP number) and 127.0.0.1. See Picture1.jpg
Picture1.jpg
.

I've tried to change port to 50 on all three posts but somehow, the post with my current IP number always get back to port 21 after a restart of the server.
And despite that the log is showing that the server is running on port 50 at the 127.0.0.1 adress (see Picture2.jpg) I can't log in to the server at that port (only on port 21).
Picture2.jpg
Can someone help me with this problem? Why doesn't the "default"-interface setting work?

Re: Can't use a different port other than 21

Posted: Sat Jun 27, 2009 6:28 pm
by CPUBUM
If you search the forum you will see this already posted

http://www.cerberusftp.com/phpBB3/viewt ... f=7&t=2295

Re: Can't use a different port other than 21

Posted: Sat Jun 27, 2009 7:51 pm
by Serin
Yeah, we've found a problem with the default interface settings not getting applied to new interfaces. Does the 85.230.xxx.xxx interface constantly change? When the interface changes, the "Default" interface settings are normally used to initialize the new interface. The problem is that the "Default" settings aren't getting applied and the interface always gets a set of hard-coded defaults. However, if once you change the settings for a detected interface, those settings should persist between restarts. The problem should only be re-occurring if you have a dynamic IP that is constantly changing to a new address every time you restart. Is that the kind of IP you have?


Thanks,

Re: Can't use a different port other than 21

Posted: Sun Jun 28, 2009 6:10 am
by Henke81
I read the other post and went to the interfaces.xml (in the: "\Cerberus LLC\Cerberus FTP Server"-folder), changed the "listenPort" to 50 on my current IP number, saved and opened up CFTPS again but STILL the listening port on the "85.230.xxx.xxx" interface was 21.

When I opened up interfaces.xml again, the "listenPort" value had been changed back to 21?!? I checked the settings.xml and the default port number there is 50.
I don't know where the app get's the info on using the port 21 but is sure does every time I restart the server.

I have a dynamic IP adress that changes between 5 different IP# (a different IP# for every startup) so I really need the "default" function to work.
Please help!

Re: Can't use a different port other than 21

Posted: Mon Jun 29, 2009 2:19 am
by Serin
I just posted a new BETA that should fix the Default interfaces problem. Use the auto-update feature from the Help menu to upgrade to beta 15.

Re: Can't use a different port other than 21

Posted: Mon Jun 29, 2009 4:25 am
by Henke81
Hi, I updated the server to beta 15 and now I can modify the interfaces.xml so that the changes to the ports is still there (changed my current IP interface listening port to 50) even after a restart of the server. But the GUI won't listen! After at restart of the server it still shows: "Interface 2 listening at 85.230.xxx.xxx on port 21" and I can only reach the server through that port :shock:

It seemes like the GUI won't listen to the settings.xml, nor the default settings but is holding on to port 21 anyway.
Looking forward to another update. :?

Re: Can't use a different port other than 21

Posted: Mon Jun 29, 2009 5:20 pm
by Serin
This is very frustrating because we can't seem to duplicate the problem here, no matter how we run the program, and only a very small number of users seem to experience it.

To clarify your problem, you can now make changes to the interfaces, through the Server Manager->Interfaces tab, and those changes persist in the GUI display even after a restart. What I mean is, you can go back to the Server Manager->Interfaces tab and you see the changes you made still persisting for the interfaces.

The problem is that the actual interface seems to get started with the default port 21 ever time, no matter what the Interfaces tab says. Correct?

Re: Can't use a different port other than 21

Posted: Tue Jun 30, 2009 6:29 am
by Henke81
In the Server Manager -> Interfaces tab I have three different posts. Default, my current IP number (wich changes quite often because of having a dynamic IP from my ISP) and 127.0.0.1 (look at Picture1 in my first post).
When I make changes to the Default and 127.0.0.1 posts, it stays like that even after a restart of the GUI. But when I change the port# on the IP adress (or try to change any of the other options like "Use a DNS service") it will always go back to the default settings after a restart of the server (port # 21, PASV Options: Don't Use External IP for Local Connecions box checked, Auto Detect box checked and so forht).

Somehow the GUI overrides the "Default" interface and use the IP adress Interface ("85.230.xxx.xxx) all the time.

I have also tried to make it work by changing the port setting of my IP adress from 21 to 50 in the "interfaces.xml"-document but even after that it still changes back to port 21 after a restart of the GUI :(

Re: Can't use a different port other than 21

Posted: Tue Jun 30, 2009 2:45 pm
by mdj
Just a silly question; are you editing the xml while the program is running? Stop the program completely, edit the xml, start the program. Probably not the problem, but anyway...

Re: Can't use a different port other than 21

Posted: Tue Jun 30, 2009 5:08 pm
by Henke81
The GUI is not running. I have also checked that it isn't running as a service.
I have the following data on my active IP interface in the "interfaces.xml"-file:

<interface name="85.230.xxx.xxx">
<requiresSecureData>false</requiresSecureData>
<requiresSecureControl>false</requiresSecureControl>
<dontUseExternalIPForLocal>true</dontUseExternalIPForLocal>
<passiveAddress></passiveAddress>
<passiveMode>0</passiveMode>
<passiveDNS></passiveDNS>
<allowLogin>true</allowLogin>
<active>true</active>
<connectionLimit>700</connectionLimit>
<listenPort>21</listenPort>
</interface>


When I change the listenPort to 50, save, exit the file and startup the GUI, the log shows: "Interface 0 listening at 85.230.xxx.xxx on port 21".
If i then open up the "interfaces.xml" again, the listenPort value has changed back to 21 again... :!: :? :(

Re: Can't use a different port other than 21

Posted: Thu Jul 02, 2009 3:44 pm
by CPUBUM
Can we please get an update on with the 3.0 will be fixed for the PORT issue you are aware of?

Thanks!

Re: Can't use a different port other than 21

Posted: Fri Jul 03, 2009 9:33 pm
by Serin
We are aware that a very small number of users (2) have reported an issue with dynamic interfaces not getting saved but we are currently unable to duplicate the problem. Everything works fine for us, no matter how many different ways we try it. We will continue to work to try to duplicate the reported issue, but until we can reproduce the problem we cannot fix it.