NEW BETA 3 INSTALL PACKAGE DOESN'T WORK!!:(

Think you've found a bug in a BETA version of Cerberus FTP Server? Post a description here.
Locked
User avatar
Rambo
User
Posts: 17
Joined: Sun May 30, 2004 6:13 pm
Contact:

NEW BETA 3 INSTALL PACKAGE DOESN'T WORK!!:(

Post by Rambo » Mon Jun 07, 2004 1:42 pm

Serin,
I managed to download your BETA 3 version, I cant wait for it to work, and when I load the Install Icon, the installation process starts to work and then it comes up with an error saying:
"There is a problem with this Windows Installer Package. A program requiredfor this install to complete could not run. Contact your support personnel or package vendor."
Why wont it work Serin??
Please reply back because I really would like to start using the BETA 3 version. Anyone who has this problem, please say so here because I hope it is not just me.

My info just incase you want to contact me is:
Email: guitargeek@ntlworld.com
OS & Version: Microsoft Windows XP Professional, Version 2002, Service Pack 1.
Cerberus FTP Server Version: 2.2 BETA 2
I cant exactly give a log file for this!! I hope we can fix this....
Tim.
Live life to its fullest....... HAVE FUN!!

Tornado
Senior User
Posts: 234
Joined: Tue Jun 08, 2004 9:39 am
Location: Australia

Post by Tornado » Tue Jun 08, 2004 10:10 am

The Windows Installer application running on your XP machine has corrupted or has something wrong with it. Cerberus doesn't include the package and thus requires that your system already has it properly installed.

You will need to research into the installer application. Microsoft states "Windows XP contains Windows Installer 2.0 and therefore can't be installed or upgraded by this redistributable."

Use google and type "Windows Installer".

Hope this helps you.

User avatar
Rambo
User
Posts: 17
Joined: Sun May 30, 2004 6:13 pm
Contact:

Post by Rambo » Tue Jun 08, 2004 12:37 pm

Hi Tornado,
It can't be corrupted or is broken in any way, because I managed to install the 2.2 BETA 2 version with the Windows Installer.
So it must lie within the installer package.....
Help me please!!,
Tim.
Live life to its fullest....... HAVE FUN!!

Tornado
Senior User
Posts: 234
Joined: Tue Jun 08, 2004 9:39 am
Location: Australia

Post by Tornado » Tue Jun 08, 2004 6:59 pm

As I recall, (someone please correct my if I'm wrong), but the 2.2 BETA 2 version didn't come as a .MSI file for installation so the windows installer was never invoked. Instead, all the files were already present in a directory and the main executable just had to be run.

I'd recommend running a test on your windows installer, by obtaining another .MSI from somewhere and attempting to execute this. If it fails, then you know the windows installer on your system is the problem. If it suceeds, then something must be wrong here (which I doubt).

User avatar
Serin
Site Administrator
Posts: 1785
Joined: Sat Jan 01, 2005 6:57 pm
Location: United States
Contact:

Post by Serin » Wed Jun 09, 2004 2:10 pm

Hello Rambo,

Tornado is correct, 2.2 BETA 2 was not packaged as a Windows Installer project. I have successfully tested the Windows Installer package for BETA 3 on Windows XP, 2000, and NT 4 without problem.

I would do a web search on whatever error message you are getting from the Windows Installer package.

dj02
New User
Posts: 8
Joined: Sat Aug 14, 2004 9:09 am
Location: Finland - North Europe
Contact:

Post by dj02 » Sat Aug 14, 2004 11:45 am

Next Cerberus installer could include Windows Installer.
I have got Windows XP Professional SP1 and i couldn't install Cerberus 2.2 BETA3 because while installing i get an error. I haven't found in google Windows Installer.
By

Dj02 / Mika
----------------------------------------------------
Homepage: http://www.dj02.net/
Habbopage: http://www.pronssikala.net/

User avatar
Serin
Site Administrator
Posts: 1785
Joined: Sat Jan 01, 2005 6:57 pm
Location: United States
Contact:

Post by Serin » Thu Aug 19, 2004 5:58 pm

There really isn't any good reason to add 3 megs of Windows Installer to a 500 KB package. Most modern version of Windows have Windows Installer built in.

Besides, including Windows Installer wouldn't fix any problems you are having with Windows XP SP1. That OS already includes the latest version. Your problem is related to problems with your XP installation.

dj02
New User
Posts: 8
Joined: Sat Aug 14, 2004 9:09 am
Location: Finland - North Europe
Contact:

Post by dj02 » Sun Aug 22, 2004 8:41 am

:( Could u do version which includes Installer.
By

Dj02 / Mika
----------------------------------------------------
Homepage: http://www.dj02.net/
Habbopage: http://www.pronssikala.net/

User avatar
Serin
Site Administrator
Posts: 1785
Joined: Sat Jan 01, 2005 6:57 pm
Location: United States
Contact:

Post by Serin » Tue Aug 31, 2004 12:09 am

See previous post.

Coyote

Same error here...

Post by Coyote » Mon Sep 20, 2004 4:44 pm

Having the same error here but on a NT4 server which meets the posted specs. I have even tried the older msi version and the same error pops up.

Coyote

Fixed.

Post by Coyote » Mon Sep 20, 2004 4:55 pm

When the installer gives the error do not close it. Leave it and try running the Cerberus from the program menu. You may see it is missing the file shlwapi.dll. Go to www.dll-files.com to download. Place this in the windows/system directory or depending on your OS it may be the system32 directory. Run the install again and it should work.

utisoft
Posts: 1
Joined: Fri Mar 04, 2005 3:07 am
Contact:

Update

Post by utisoft » Fri Mar 04, 2005 3:12 am

There is a new MSI package in Windows XP Service Pack 2. You probably need to install that.
Chris

Locked