No Upload Progress Bar - 2.2 Beta 3

Think you've found a bug in a BETA version of Cerberus FTP Server? Post a description here.
Locked
openpit

No Upload Progress Bar - 2.2 Beta 3

Post by openpit » Tue Jun 29, 2004 10:13 pm

When uploading I get "In Progress" instead of a percent complete bar regardless of the status of the "Use Optimized File Sending" toggle button.

I removed 2.2 Beta 3, then reinstalled 2.16 and the progress bar reappears.

Otherwise, thanks for an excellent program.

User avatar
Serin
Site Administrator
Posts: 1785
Joined: Sat Jan 01, 2005 6:57 pm
Location: United States
Contact:

Post by Serin » Tue Jun 29, 2004 11:48 pm

Hello,

The progress bar never appeared when a user was uploading to the server. The nature of the FTP protocol prevents a server from knowing how big an uploaded file is going to be. The server simply writes bytes to a file until the client closes the connection.

However, when "Use optimized file transfers" is enabled, the server will only show in-progress. This is because the server hands the file off to the OS to perform a kernel-level tranfer. There is no status returned regarding transfer progress, so Cerberus cannot update the GUI. I may find a workaround for this in the next release or two.

openpit

Post by openpit » Wed Jun 30, 2004 12:18 pm

I condition am speaking about is when a client is downloading from my server.

Sorry for the confusion.

User avatar
Serin
Site Administrator
Posts: 1785
Joined: Sat Jan 01, 2005 6:57 pm
Location: United States
Contact:

Post by Serin » Thu Jul 01, 2004 8:15 am

See the second paragraph of my previous post then.

Locked