Cerberus 2.32 --> can't log in with IE

Questions dealing with specific FTP clients and Cerberus FTP Server.
Post Reply
Broz
New User
Posts: 3
Joined: Mon Sep 05, 2005 1:04 pm

Cerberus 2.32 --> can't log in with IE

Post by Broz » Mon Sep 05, 2005 1:45 pm

Hi,

We have been using a previous version of Ceberus FTP server for quite some time now, and with great satisfaction, but after a computer crash we had to download and install the new version, 2.32, and now we have a problem.

The problem is this: Each time I try to log in using Internet Explorer it gives an error:

" "FTP Folder Error"
An error occured opening that folder on the FTP Server. Make sure you
have permission to access that folder.

Details: A connection with the server could not be established "

But I haven't even tried to access any folder yet! I have set all the permissions of all the folders to "allow all", I have allowed unlimited users, I have tried not using a password, but it doesn't seem to work.
Next to that: Logging in and downloading files works with WS_FTP Pro like a charm, but unfortunately not all users have that program.

The log that Cerberus gives me during this procedure is the following:

Mon Sep 05 19:20:49 2005 541 Incoming connection request on interface 192.168.1.1
Mon Sep 05 19:20:49 2005 541 Connection request accepted from 192.168.0.5
Mon Sep 05 19:20:49 2005 541 USER anonymous
Mon Sep 05 19:20:49 2005 541 331 User anonymous, password please
Mon Sep 05 19:20:49 2005 541 PASS ***********
Mon Sep 05 19:20:49 2005 541 Logon failure: The user name did not belong to a valid NT user
Mon Sep 05 19:20:53 2005 541 530 Not logged in. Username/password incorrect, user disabled, or user logged in too many times
Mon Sep 05 19:20:53 2005 541 The connection was closed by the remote socket.
Mon Sep 05 19:20:53 2005 541 Connection terminated.
Mon Sep 05 19:20:53 2005 542 Incoming connection request on interface 192.168.1.1
Mon Sep 05 19:20:53 2005 542 Connection request accepted from 192.168.0.5
Mon Sep 05 19:20:53 2005 542 USER anonymous
Mon Sep 05 19:20:53 2005 542 331 User anonymous, password please
Mon Sep 05 19:20:53 2005 542 PASS ***********
Mon Sep 05 19:20:53 2005 542 Logon failure: The user name did not belong to a valid NT user
Mon Sep 05 19:20:57 2005 542 530 Not logged in. Username/password incorrect, user disabled, or user logged in too many times
Mon Sep 05 19:20:57 2005 542 The connection was closed by the remote socket.
Mon Sep 05 19:20:57 2005 542 Connection terminated.
Mon Sep 05 19:20:57 2005 543 Incoming connection request on interface 192.168.1.1
Mon Sep 05 19:20:57 2005 543 Connection request accepted from 192.168.0.5
Mon Sep 05 19:20:57 2005 543 USER Warner
Mon Sep 05 19:20:57 2005 543 331 User Warner, password please
Mon Sep 05 19:20:57 2005 543 PASS ***********
Mon Sep 05 19:20:57 2005 543 230 Password Ok, User logged in
Mon Sep 05 19:20:57 2005 543 OPTS utf8 on
Mon Sep 05 19:20:57 2005 543 501 Unsupported feature
Mon Sep 05 19:20:57 2005 543 SYST
Mon Sep 05 19:20:57 2005 543 215 UNIX Type: L8
Mon Sep 05 19:20:57 2005 543 SITE help
Mon Sep 05 19:20:57 2005 543 502 Unknown site command
Mon Sep 05 19:20:57 2005 543 PWD
Mon Sep 05 19:20:57 2005 543 257 "/" is the current directory
Mon Sep 05 19:20:57 2005 544 Incoming connection request on interface 192.168.1.1
Mon Sep 05 19:20:57 2005 544 Connection request accepted from 192.168.0.5
Mon Sep 05 19:20:57 2005 544 USER Warner
Mon Sep 05 19:20:57 2005 544 331 User Warner, password please
Mon Sep 05 19:20:57 2005 544 PASS ***********
Mon Sep 05 19:20:57 2005 544 230 Password Ok, User logged in
Mon Sep 05 19:20:57 2005 544 OPTS utf8 on
Mon Sep 05 19:20:57 2005 544 501 Unsupported feature
Mon Sep 05 19:20:57 2005 544 SYST
Mon Sep 05 19:20:57 2005 544 215 UNIX Type: L8
Mon Sep 05 19:20:57 2005 544 SITE help
Mon Sep 05 19:20:57 2005 544 502 Unknown site command
Mon Sep 05 19:20:57 2005 544 PWD
Mon Sep 05 19:20:57 2005 544 257 "/" is the current directory
Mon Sep 05 19:20:57 2005 544 TYPE A
Mon Sep 05 19:20:57 2005 544 200 Type ASCII
Mon Sep 05 19:20:57 2005 544 PASV
Mon Sep 05 19:20:57 2005 544 227 Entering Passive Mode (130,xx,xxx,xx,4,58)

Next to that, logging in with Mozilla Firefox doesn't work either, seems like the same problem. The log looks like this:

Mon Sep 05 19:40:07 2005 551 Incoming connection request on interface 192.168.1.1
Mon Sep 05 19:40:07 2005 551 Connection request accepted from 192.168.0.5
Mon Sep 05 19:40:07 2005 551 USER Warner
Mon Sep 05 19:40:07 2005 551 331 User Warner, password please
Mon Sep 05 19:40:07 2005 551 PASS ***********
Mon Sep 05 19:40:07 2005 551 230 Password Ok, User logged in
Mon Sep 05 19:40:07 2005 551 SYST
Mon Sep 05 19:40:07 2005 551 215 UNIX Type: L8
Mon Sep 05 19:40:07 2005 551 PWD
Mon Sep 05 19:40:07 2005 551 257 "/" is the current directory
Mon Sep 05 19:40:07 2005 551 TYPE I
Mon Sep 05 19:40:07 2005 551 200 Type Binary
Mon Sep 05 19:40:07 2005 551 PASV
Mon Sep 05 19:40:07 2005 551 227 Entering Passive Mode (130,xx,xxx,xx,4,63)
Mon Sep 05 19:40:07 2005 551 SIZE /
Mon Sep 05 19:40:07 2005 551 213 0
Mon Sep 05 19:40:07 2005 551 MDTM /
Mon Sep 05 19:40:07 2005 551 213 19790101000000
Mon Sep 05 19:40:07 2005 551 RETR /
Mon Sep 05 19:40:07 2005 551 500 User does not have download permission
Mon Sep 05 19:40:07 2005 551 PASV
Mon Sep 05 19:40:07 2005 551 227 Entering Passive Mode (130,xx,xxx,xx,4,64)
Mon Sep 05 19:40:07 2005 551 CWD /
Mon Sep 05 19:40:07 2005 551 250 Change directory ok
Mon Sep 05 19:40:07 2005 551 LIST

Well, I am at a loss, any help would be greatly appreciated.

Thanks in advance,

Warner

Tornado
Senior User
Posts: 234
Joined: Tue Jun 08, 2004 9:39 am
Location: Australia

Post by Tornado » Tue Sep 06, 2005 12:00 am

It appears to be a basic configuration problem at best guess. Also I dont recall cerberus having an option of "allow all".

For the user Warner, try the following:-
Is Anonymous = false
Password = <your own password>
Simultaneous Logins = Unlimited
Simple Directories = false
Account Is Disabled = false

For testing purposes:-
1. create a virtual directory (down the bottom on the same screen) to "C:\".
2. On the left hand side, select "C"
3. On the right hand side select all 6 permissions

Thats it. Give this a go!

arichardson
New User
Posts: 3
Joined: Mon Dec 05, 2005 8:17 pm

Post by arichardson » Mon Dec 05, 2005 8:49 pm

I am having the same problem with my FTP server. Trying to connect to the internal IP of the machine brings up the same error after I login, and I get the same log information too. I've tried a few things (changing default directory, logging on as different users, trying NT authentication). Nothing works.

Thanks in advance

EDIT: already tried what you suggested, but that didnt work either

Broz
New User
Posts: 3
Joined: Mon Sep 05, 2005 1:04 pm

Post by Broz » Tue Dec 06, 2005 6:48 am

Hi Arichardson,

I found out that IE (and firefox as well) use another way of authentification compared to programs such as WS_FTP: some difference concerning passive and active mode.
The problem, in my situation, was that my (stand-alone) firewall/router was blocking the login procedure. The problem was solved by forwarding not only port 21 to the FTP server, but the range 1025:1337 as well (or something alike).

Hope it helps you out!

(oh, by the way Tornado: thanx for your reply a while back. By describing the option 'allow all' I ment selection all 6 permissions ;-))

honeymic
Posts: 1
Joined: Tue Dec 13, 2005 8:56 am

IE Probs

Post by honeymic » Tue Dec 13, 2005 10:42 am

Hello all,

New to the forum but I found a work around here on this very issue I was having problems as well. One of my friends could not access it through IE as well. I had him uncheck the option for Passive FTP in the advanced options and it seems to work fine now. Maybe this will help, it seemed to me..... good luck!!!

Broz
New User
Posts: 3
Joined: Mon Sep 05, 2005 1:04 pm

Post by Broz » Tue Dec 13, 2005 12:45 pm

Yes Honeymic, I also found out that unchecking the option for passive FTP proved to be a solution, but my main problem was that I didn't want to ask this change from all users. I don't know how to adaps windows' firewall to let the connection through though..

Warner

Post Reply