Unable to connect to server

Questions dealing with specific FTP clients and Cerberus FTP Server.
Post Reply
devil900
New User
Posts: 8
Joined: Thu Jan 07, 2010 2:06 am

Unable to connect to server

Post by devil900 » Thu Jan 07, 2010 2:25 am

I have an issue connecting to the server. I have filezilla client and below is the log from both server and client

Server
20100107110251 Cerberus added to Windows Firewall Exception list
20100107110251 Interface 0 listening at 192.168.xx.xx on port 21
20100107110254 WAN IP detected as 92.98.xx.xx

Client
Status: Resolving address of xxx.no-ip.org
Status: Connecting to 92.98.xx.xx:21...
Status: Connection established, waiting for welcome message...
Response: 220 FTPU ready.
Command: USER [hidden]
Response: 331 Password required for [hidden].
Command: PASS ******
Response: 530 Login incorrect.
Error: Critical error
Error: Could not connect to server

Ports:
Server:
FTP: 21
Passive: 60010-60779

Can anyone help.

Note: I am able to connect though local address

mdj
Moderator
Posts: 656
Joined: Mon Aug 18, 2003 4:00 am
Location: Denmark
Contact:

Re: Unable to connect to server

Post by mdj » Thu Jan 07, 2010 2:57 am

There must be some more in the server log, it doesn't show the connection attempt at all.
Morten Due Jørgensen
http://www.mdjnet.dk

devil900
New User
Posts: 8
Joined: Thu Jan 07, 2010 2:06 am

Re: Unable to connect to server

Post by devil900 » Thu Jan 07, 2010 7:00 am

Thank you for replying back.

this is exactly what i am wondering about. FTP client seems to connect and fails.
no-ip.com has "can you see me" http://www.canyouseeme.org/ open port check tool

following is the result:
Success: I can see your service on 92.98.xx.xx on port (21)
Your ISP is not blocking port 21

Cerberus Server recognizes that there is an attempt with the following log:
[2010-01-07 15:57:01]:CONNECT [ 0] - Incoming connection request on interface 192.168.xx.xx
[2010-01-07 15:57:01]:CONNECT [ 0] - Connection request accepted from 204.16.xx.xx
[2010-01-07 15:57:01]: WARN [ 0] - Closing connection: An existing connection was forcibly closed by the remote host.
[2010-01-07 15:57:01]:CONNECT [ 0] - Connection Terminated

I made a conclusion that the ftp client is not even attempting to connect to the server.

I have additionally checked port 20, below is the result:
Error: I could not see your service on 92.98.xx.xx on port (20)
Reason: Connection refused

Appreciate your help

mdj
Moderator
Posts: 656
Joined: Mon Aug 18, 2003 4:00 am
Location: Denmark
Contact:

Re: Unable to connect to server

Post by mdj » Thu Jan 07, 2010 9:55 am

Yes, it could look like the client is not doing what it is supposed to. I can't see anything specific in the client log, try to compare a client log from the inside with the client log from the outside.
Morten Due Jørgensen
http://www.mdjnet.dk

devil900
New User
Posts: 8
Joined: Thu Jan 07, 2010 2:06 am

Re: Unable to connect to server

Post by devil900 » Thu Jan 07, 2010 10:33 am

mdj wrote:Yes, it could look like the client is not doing what it is supposed to. I can't see anything specific in the client log, try to compare a client log from the inside with the client log from the outside.
Following are the logs:

Connecting with local address:
Client Log:
Status: Connecting to 192.168.xx.xx:21...
Status: Connection established, waiting for welcome message...
Response: 220-Cerberus FTP Server - Personal Edition
Response: 220-UNREGISTERED
Response: 220 Welcome to FTP Server
Command: USER [Hidden]
Response: 331 User [Hidden], password please
Command: PASS ******
Response: 230 Password Ok, User logged in
Command: OPTS UTF8 ON
Response: 220 UTF8 support on
Status: Connected
Status: Retrieving directory listing...
Command: PWD
Response: 257 "/" is the current directory
Command: TYPE I
Response: 200 Type Binary
Command: PASV
Response: 227 Entering Passive Mode (192,168,0,12,234,137)
Command: MLSD
Response: 150 Opening data connection
Response: 226 Transfer complete
Status: Directory listing successful

Server log:
[2010-01-07 19:26:54]:CONNECT [ 1] - Incoming connection request on interface 192.168.xx.xx
[2010-01-07 19:26:54]:CONNECT [ 1] - Connection request accepted from 192.168.xx.xx
[2010-01-07 19:26:54]:COMMAND [ 1] - USER [hidden]
[2010-01-07 19:26:54]: REPLY [ 1] - 331 User [hidden], password please
[2010-01-07 19:26:54]:COMMAND [ 1] - PASS ***********
[2010-01-07 19:26:54]: REPLY [ 1] - 230 Password Ok, User logged in
[2010-01-07 19:26:54]:COMMAND [ 1] - OPTS UTF8 ON
[2010-01-07 19:26:54]: REPLY [ 1] - 220 UTF8 support on
[2010-01-07 19:26:54]:COMMAND [ 1] - PWD
[2010-01-07 19:26:54]: REPLY [ 1] - 257 "/" is the current directory
[2010-01-07 19:26:54]:COMMAND [ 1] - TYPE I
[2010-01-07 19:26:54]: REPLY [ 1] - 200 Type Binary
[2010-01-07 19:26:54]:COMMAND [ 1] - PASV
[2010-01-07 19:26:54]: REPLY [ 1] - 227 Entering Passive Mode (192,168,0,12,234,137)
[2010-01-07 19:26:54]:COMMAND [ 1] - MLSD
[2010-01-07 19:26:54]: REPLY [ 1] - 150 Opening data connection
[2010-01-07 19:26:54]: REPLY [ 1] - 226 Transfer complete

Once i attempt to connect though no-ip, no changes on server log.
here is the PASV mode port range
60010 - 60779

devil900
New User
Posts: 8
Joined: Thu Jan 07, 2010 2:06 am

Re: Unable to connect to server

Post by devil900 » Thu Jan 07, 2010 10:35 am

i have tested internet expolorer as different client to connect through ftp, it keeps prompting the user ID and password

mdj
Moderator
Posts: 656
Joined: Mon Aug 18, 2003 4:00 am
Location: Denmark
Contact:

Re: Unable to connect to server

Post by mdj » Fri Jan 08, 2010 4:08 am

This server log is very different from the first one you posted. This second log shows that the client is indeed writing out the welcome message from the server:

Code: Select all

Response: 220-Cerberus FTP Server - Personal Edition
Response: 220-UNREGISTERED
Response: 220 Welcome to FTP Server
The first log shows:

Code: Select all

Response: 220 FTPU ready.
- so if there is no change in the server log, it must be because there are no loggings at all in the server log when connecting through no-ip, because it is not connecting to the right FTP server.
Morten Due Jørgensen
http://www.mdjnet.dk

devil900
New User
Posts: 8
Joined: Thu Jan 07, 2010 2:06 am

Re: Unable to connect to server

Post by devil900 » Fri Jan 08, 2010 11:44 am

I thought it could be the same conclusion; however, the website http://www.canyouseeme.org/ and no-ip client have the same IP address. the server has a log when connecting though http://www.canyouseeme.org/ but it does not have it when i connect through a client over port 21.

I have also no other application that runs on port 21. i have checked that.

Is there a way to restore default values for the server. i might be able to start from there.

devil900
New User
Posts: 8
Joined: Thu Jan 07, 2010 2:06 am

Re: Unable to connect to server

Post by devil900 » Fri Jan 08, 2010 5:42 pm

Hello, I aapreciate all your help, but i would like to add an update.
I have checked http://my dynamicdns/ opens the router main page.
does that mean that the ftp request does not get through the router eventhough i have forwarded the passive mode ports?

should i place the server in DMZ?

mdj
Moderator
Posts: 656
Joined: Mon Aug 18, 2003 4:00 am
Location: Denmark
Contact:

Re: Unable to connect to server

Post by mdj » Sun Jan 10, 2010 7:13 am

I really can't tell, as I have no idea how these services are implemented... It just looks like port 21 on no-ip is forwarded somewhere else. That is all I can see.
Morten Due Jørgensen
http://www.mdjnet.dk

devil900
New User
Posts: 8
Joined: Thu Jan 07, 2010 2:06 am

Re: Unable to connect to server

Post by devil900 » Sun Jan 10, 2010 10:50 am

Thanks anyways.
I will keep trying.

just to add an note
Cerberus FTP is the most user friendly personal FTP server GUI i have ever tested .. keep it up.

devil900
New User
Posts: 8
Joined: Thu Jan 07, 2010 2:06 am

Re: Unable to connect to server

Post by devil900 » Thu Jan 21, 2010 6:04 pm

Hi there,

wanted to share with you how it was resolved,

I had to disable loopback from hosts file by adding (#)

# 127.0.0.1 localhost

<Drive>:\Windows\System32\Drivers\etc\Hosts

That worked perfectly fine.

Thanks

Post Reply