Page 1 of 1

521 Not logged in - Secure authentication

Posted: Mon Jul 16, 2012 7:58 am
by Marco
After updating Cerberus from vrsion 5.0.2 to 5.0.4 i can't connect to the FTP. From Cerberus LOG Board i have such a message:

2012/07/16 13:38:47 [27] 521 Not logged in - Secure authentication required
2012/07/16 13:38:47 [27] The client closed the connection
2012/07/16 13:38:47 [27] Connection terminated

Before update everthing worked fine. I've tried already changing configuration with Secure Control and Secure Data selected but nothing has changed. I have to say that I'm trying to connect from the same machine where serever is build. Any clue whet's wrong?

Re: 521 Not logged in - Secure authentication

Posted: Mon Jul 16, 2012 10:12 am
by Serin
Hello,

It is one of two issues. Either the FTP interface is set to allow only encrypted FTP connections or the user account is configured to only allow encrypted FTP connections. The require encryption setting can be enabled at either the interface or user level.

Go to the Interfaces tab of the Server manager and select the FTP interface matching the IP address your users are logging in on. This is not the same as the Default interface. Check out the Interfaces help for more information on the difference.

You can remove the requirement for secure connections by unchecking the "Require Secure Control" and "Require Secure Data" options for the interface.

You should also check the user account in the User Manager. Click on the Constraints tab for the user and see if the above two options are set.


However, the better answer is to just switch to an FTP client that supports FTPES connections and use encryption. Using plain, unencrypted FTP is not recommended.

Re: 521 Not logged in - Secure authentication

Posted: Fri Sep 07, 2012 2:07 am
by Serin
I thought I would update this post with more information. If you wish to allow unsecured FTP connections, follow the instructions in this FAQ entry:

How can I configure the server to allow unencrypted FTP connections?